Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360

Notices

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #11  
Old July 1st, 2018
DPJ DPJ is offline
Junior Member
 
Join Date: Jun 2018
Posts: 3
Default issue since 2016.

Hello again,

I see on the forums that this Bluetooth icon issue has been going on for years.

This is from a moderator back in 2016:
There have been reports of some seeing the bluetooth icon on the detector with no speed limit sign. If you see this then try to update the detector and it fails the update then there is a problem with the detector.

-----------------------------------------------------------------

So, does the item have to be inspected or is this an ongoing unsolvable issue?
  #12  
Old July 2nd, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 17,083
Default

This issue has not gone on non-stop since then. Certain Android phones and Android OS versions have had issues with Escort Live while others work better.

You can try to un-pair and pair your Max 360 again.

Android has recently released OS updates which solves bluetooth connection issues. The next version of Escort Live will also have a new pairing mechanism which should resolve many bluetooth connection issues. I don't have an ETA for the update.
__________________

Escort Radar customer service is available from 9am-5:00pm Eastern Time Mon-Fri at 1-800-543-1608 or you can fill out a repair form and we will contact you.
  #13  
Old July 4th, 2018
GumbyDammit223 GumbyDammit223 is offline
Senior Member
 
Join Date: Dec 2016
Posts: 151
Default

It's the first time in months I've actually driven more than a couple miles at a time and have been able to actually use EL. The phone is a Samsung Edge 7 running standard Verizon Oreo. In order for the M360 to display speed limits or receive any sort of information from EL, EL MUST remain open at all times on the phone. If you bring up the home screen, EL goes dormant and is useless. Locking your phone shuts it down as well. I just finished driving a 360+ mile loop and my fully charged battery at the start was completely drained by having EL active the entire time.

I really hope a firmware update will be forthcoming because Oreo blows goats and has rendered numerous things on the phone worthless with EL being one of them.
  #14  
Old July 6th, 2018
Stinger22 Stinger22 is offline
Junior Member
 
Join Date: Mar 2017
Posts: 22
Default

I'm on a Samsung S8 with latest updates and quite often with the 360 connected via BT still only get the blue BT symbol instead of the PSL even though EL is showing it on the phone. And still occasional "cannot connect to gps services" even though other apps are using gps services.

I have to stop the app and back on or restart the detector to get it to display.

The strange one is sometimes when the 360 is running and I turn on EL and nothing so I touch the BT symbol for the app and it says the "radar detector is not intialized" even though it is operating just fine. I have to restart the detector.
  #15  
Old July 7th, 2018
GumbyDammit223 GumbyDammit223 is offline
Senior Member
 
Join Date: Dec 2016
Posts: 151
Default

Here are a couple threads talking about Oreo (Android 8) and EL:

http://www.escortradarforum.com/foru...ad.php?t=17728

http://www.escortradarforum.com/foru...ad.php?t=17796

In essence, Oreo screwed us w.r.t. Bluetooth connectivity and Escort needs to find a workaround.
  #16  
Old March 22nd, 2021
oengus oengus is offline
Junior Member
 
Join Date: Jul 2010
Posts: 19
Default

Tried all of this and still not displaying local speed limits.
  #17  
Old March 9th, 2022
Gearman's Avatar
Gearman Gearman is offline
Member
 
Join Date: Jun 2014
Posts: 63
Default

Somehow I lost speed limit within the last week also
Has been working very well for few years, now issues! Is this a way to try and get me to upgrade?!?!


Sent from my iPhone using Tapatalk Pro
  #18  
Old May 15th, 2022
SuperNuts SuperNuts is offline
Junior Member
 
Join Date: Sep 2017
Posts: 8
Default

I've also had this problem for the past 2 months or so. Thought it would eventually fix itself, but it didn't. I have both subscriptions active, defender database and live premium.
  #19  
Old May 15th, 2022
mtime mtime is offline
Senior Member
 
Join Date: Jun 2015
Posts: 367
Default

Escort server / cloud issues. See other threads for further explanation. Escort working on it; no ETA
  #20  
Old May 16th, 2022
flylow7f39 flylow7f39 is offline
Moderator
 
Join Date: Nov 2010
Posts: 3,986
Default

This thread was started 4 years ago...

Kindly continue the discussion in http://escortradarforum.com/forums/s...ad.php?t=19992
__________________
__________________________________________________ ______________________________________
Moderators here are not Escort employees.

If you need immediate help give Escort Radar customer service a call right after they open at 1-800-543-1608, option 2, available from 9am-5:30pm Eastern Time Mon-Fri. Wait for the pause following the message and use the option for a call back.
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:33 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.