Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > Passport 9500ci

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old September 15th, 2022
DDLexus DDLexus is offline
Junior Member
 
Join Date: May 2017
Posts: 9
Default GPS Intermittently Working

A 9500ci was recently installed in my car. After starting and driving the car for 40min, the GPS appeared to be working properly (showing my GPS speed on the display). After shutting the car off to fill the gas tank, i started the car again and the GPS showed a blinking icon and indicated a 0 MPH speed. The GPS blinked for the remainder of my 30min drive, never reestablishing GPS signal and speed.

The next day, i started the car and the GPS was working again. Same thing happened, I drove about 30min and turned off the car for about 15 minutes, then restarted the car and the GPS flashed and showed 0 MPH for the remainder of my 40 min drive. Note, no errors ever display.

I've ruled out the GPS puck location. I moved it around the car while it was not connected, even holding it out the window, and no change. Plus, it worked while it was firmly mounted.

I know GPS was updated in a firmware release many years ago, but I'm not sure how to check what version my 9500ci is on. I assume I have the latest firmware installed.

Any idea why the GPS works after the car sits for several hours but not after a short (5-15min) cycle?
Reply With Quote
  #2  
Old September 19th, 2022
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 1,938
Default

I'd start with making sure it's updated 100%. You need the usb dongle and proper cord and hook it into a PC with the Detector Tools installed to check that.


Quote:
Originally Posted by DDLexus View Post
A 9500ci was recently installed in my car. After starting and driving the car for 40min, the GPS appeared to be working properly (showing my GPS speed on the display). After shutting the car off to fill the gas tank, i started the car again and the GPS showed a blinking icon and indicated a 0 MPH speed. The GPS blinked for the remainder of my 30min drive, never reestablishing GPS signal and speed.

The next day, i started the car and the GPS was working again. Same thing happened, I drove about 30min and turned off the car for about 15 minutes, then restarted the car and the GPS flashed and showed 0 MPH for the remainder of my 40 min drive. Note, no errors ever display.

I've ruled out the GPS puck location. I moved it around the car while it was not connected, even holding it out the window, and no change. Plus, it worked while it was firmly mounted.

I know GPS was updated in a firmware release many years ago, but I'm not sure how to check what version my 9500ci is on. I assume I have the latest firmware installed.

Any idea why the GPS works after the car sits for several hours but not after a short (5-15min) cycle?
__________________
I use the following Escort Products

Escort Redline 360c
Escort Maxcam360c
Escort Live and Drive Smarter App
-----------------------------------------------------------
If you need immediate help please contact Escort Customer service by calling 1-800-543-1608, option 2. , M-F 9:00AM-5:30PM EST.. It is best to call at opening time and choose the call back option so you can get a call back during the day.
------------------------------------------------------------
Reply With Quote
  #3  
Old September 19th, 2022
DDLexus DDLexus is offline
Junior Member
 
Join Date: May 2017
Posts: 9
Default

I used Detector Tools and tried to apply a firmware update. It said it could not update firmware, not updates are available. Something like that. I looked at the settings and it also showed Ka Band Segmentation, so I assume it has the latest firmware installed. Is there a way to see via Detector Tools what version firmware the 9500ci is running on?
Reply With Quote
Reply

Tags
firmware, flashing, gps, location

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:16 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.