Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > ESCORT X80

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 2 Weeks Ago
nross33 nross33 is offline
Junior Member
 
Join Date: Sep 2018
Location: Newport Beach, CA
Posts: 1
Default X80 Not connecting to Escort live after updating the app on iPhone

Hello All, is anyone else having this issue? A few weeks back I updated the iPhone app (Says now it is on Version 2.1.23 build 3) and ever since my x80 has not wanted to connect to the app. I can connect it to bluetooth in my device and it shows the bluetooth icon on the detector glowing blue but it won't connect to my device in escort live or show me the speed limit. It works very occasionally but only maybe 1 out of 20 times. Does anyone have this same issue? I need to resolve this as I have gotten two tickets as a result!
Reply With Quote
  #2  
Old 2 Weeks Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,058
Default

You need to connect it by using the Devices menu in Escort Live's settings menu. Do not connect it using your iPhone's Bluetooth settings menu.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:27 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.