Escort Radar Forum  

Go Back   Escort Radar Forum > Non-Detector Products > SmartMirror, SmartMirror2

Notices

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old October 2nd, 2014
er95 er95 is offline
Member
 
Join Date: Oct 2014
Posts: 80
Default Smart Mirror Always On?

My smart mirror is installed correctly. Constant 12V is connected to a constant 12V power source. Switched 12V is connected to a switched (ignition on) power source. Both verified by DVMM. But my mirror is always on.

In addition, I've disconnected the switched power wire and the mirror is still on. The screen still displays whatever was up: map, media, or Bluetooth screen.

One touch of the power switch puts the screen in standby mode. Meaning, the screen is blank, but power is still being fed to it. Its evident at night because the screen isn't off, its displaying a black color to appear off.

Holding the power switch for several seconds will turn the screen off. This appears to be the only way to turn the screen off.

Then to turn the screen back on requires either pressing the power button or putting the vehicle in reverse. When the mirror is powered down, simply turning on the ignition does not turn the mirror back on.

For any of you that have the smart mirror, do you have the same problem? Or does yours operate differently?
  #2  
Old October 2nd, 2014
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,153
Default

Re-check the SmartRadar wire labels. The SmartRadar's yellow wire is constant 12VDC and the red wire is switched 12VDC.

Also, when you reconnect the wires you will probably need to take the SD card out of the SmartMirror, plug it into a computer, delete the saved file then insert it back into the SmartMirror.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
  #3  
Old October 8th, 2014
er95 er95 is offline
Member
 
Join Date: Oct 2014
Posts: 80
Default

I confirmed, yellow is on constant 12V and red is on switched 12V. The mirror does not turn off with the ignition off.

Right now, I have JUST the yellow wire plugged in and the Smart Mirror is on. Shouldn't the mirror ONLY turn on when 12V is applied to the red wire??

(My red switched wire off the Smart Mirror is also plugged into the same switched power source as my radar detector. Which, turns on and off with the ignition. So my switched power source does indeed "switch.")

Last edited by er95; October 8th, 2014 at 06:07 PM.
  #4  
Old October 9th, 2014
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,153
Default

There must be an issue with this SmartMirror then. If it is within the return period then please contact who you purchased it from to have it replaced. To have it serviced please send me a message with your name, address, and email address or call us at the number in my signature below.

Thank you
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
  #5  
Old November 17th, 2014
er95 er95 is offline
Member
 
Join Date: Oct 2014
Posts: 80
Default

Thanks so much Escort Radar for such excellent customer service! My Smart Mirror is now working as intended.
  #6  
Old November 19th, 2014
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,153
Default

Quote:
Originally Posted by er95 View Post
Thanks so much Escort Radar for such excellent customer service! My Smart Mirror is now working as intended.
Excellent! Thank you for following up.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
  #7  
Old February 21st, 2015
jsflyrv jsflyrv is offline
Junior Member
 
Join Date: Feb 2015
Posts: 4
Default Smartmirror 2

I have a $499.00 Smartmirror2 with backup camera for just a little over a year, bought on 1/7/2014. Well now the left side of the display is going dark, so dark it is hard to see or read. this covers almost 1/3 of the left side of the GPS/backup camera screen. Really disappointed that I spent $500.00 for something that is junk in just a years time. I had always heard Escort was high quality products.
What say you Escort?
  #8  
Old February 21st, 2015
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,278
Default

Quote:
Originally Posted by jsflyrv View Post
I have a $499.00 Smartmirror2 with backup camera for just a little over a year, bought on 1/7/2014. Well now the left side of the display is going dark, so dark it is hard to see or read. this covers almost 1/3 of the left side of the GPS/backup camera screen. Really disappointed that I spent $500.00 for something that is junk in just a years time. I had always heard Escort was high quality products.
What say you Escort?
Hi Jsflyrv -

I would urge you to contact Escort directly @ 800-543-1608. The Escort Rep (EscortRadar) checks the forum, but typically on Tuesdays and Wednesdays. You'll get a much faster response if you call them. You may also want to PM EscortRadar directly.

Good luck!
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)
  #9  
Old February 21st, 2015
jsflyrv jsflyrv is offline
Junior Member
 
Join Date: Feb 2015
Posts: 4
Default

Quote:
Originally Posted by TBNTX View Post
Hi Jsflyrv -

I would urge you to contact Escort directly @ 800-543-1608. The Escort Rep (EscortRadar) checks the forum, but typically on Tuesdays and Wednesdays. You'll get a much faster response if you call them. You may also want to PM EscortRadar directly.

Good luck!

Thanks TBNTX

Last edited by jsflyrv; February 21st, 2015 at 12:19 PM.
  #10  
Old February 23rd, 2015
jsflyrv jsflyrv is offline
Junior Member
 
Join Date: Feb 2015
Posts: 4
Default

Well I heard back from Escort about my Smartmirror 2 going dark on one side after a year of very little use in my classic car. So I spent $500.00 for it and now they want another $140 to repair it plus shipping. Not going to happen I am not going to spend another $140 to repair their poor quality on something that did not even last a year.

Goodbye Escort, will never spend another dime on Escort products and recommend my friends in the auto world don't either. I don't mind paying them something to fix a out of date product but $140.00 is ridiculous.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:32 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.