Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > ESCORT iX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 2 Weeks Ago
Graminal Graminal is offline
Junior Member
 
Join Date: Mar 2019
Posts: 3
Angry iX False Alarms

I have an iX which is supposed to have software to eliminate false alarms from cars with blind spot detection. However, I get these false alarms continually on X band. Does anybody know of a fix? I have tried calling support,but I can't stay on hold for the 30 minutes wait time. Really frustrated.
Reply With Quote
  #2  
Old 2 Weeks Ago
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,587
Default

No.
Unless you absolutely need X band you may want to turn it off. Most people these days turn it off completely in Preferences. As an alternative you can use AutoNoX Mode which also suppresses X band alerts completely unless you absolutely know you need them.

If you leave X on AutoLearn will eventually learn and silence most of them. You can also manually lock them out immediately if you don't want to wait for the learning process..

Last edited by poolmon; 2 Weeks Ago at 02:48 PM.
Reply With Quote
  #3  
Old 2 Weeks Ago
Butcher318 Butcher318 is offline
Senior Member
 
Join Date: Dec 2011
Location: Indiana
Posts: 1,958
Default

Yes your IX does have Escort's IVT filtering. This is however for K band, not X band. New vehicle safety systems like CAS and BSM function on K band. In 95% of the country you can turn X band off, if you have a setting called auto Lo X you might try that. I would just run auto no X as stated above and be done.
Reply With Quote
  #4  
Old 2 Weeks Ago
Graminal Graminal is offline
Junior Member
 
Join Date: Mar 2019
Posts: 3
Default

Thanks for the replies, but the false alarms I'm getting are on K band and not on X band.

Any ideas on that? It appears to me the IVT filtering is pretty lame.

Thanks.
Reply With Quote
  #5  
Old 2 Weeks Ago
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,587
Default

Quote:
Originally Posted by Graminal View Post
Thanks for the replies, but the false alarms I'm getting are on K band and not on X band.

Any ideas on that? It appears to me the IVT filtering is pretty lame.

Thanks.
Your original post indicates the falses were on the X band.

If you are getting them on the K band you will have to upgrade to an all digital RD in the MAX lineup to get the additional K filtering they provide.
Reply With Quote
  #6  
Old 2 Weeks Ago
Graminal Graminal is offline
Junior Member
 
Join Date: Mar 2019
Posts: 3
Default

Quote:
Originally Posted by poolmon View Post
Your original post indicates the falses were on the X band.

If you are getting them on the K band you will have to upgrade to an all digital RD in the MAX lineup to get the additional K filtering they provide.
If that's the case, then the sales people at Escort need training as they are giving really inaccurate sales information. This is VERY frustrating.and that's putting it mildly.)

If i ever get them on the phone, I will try to exchange the iX.
Reply With Quote
  #7  
Old 2 Weeks Ago
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,587
Default

They both have K band filters, it's just that the all-digital MAX line can handle additional filter capabilities that the part analog iX cannot.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:15 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.