Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > Passport 9500ci

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old April 18th, 2017
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 14,278
Default

There's nothing evident from your description or from the pictures as to why the buttons are not responding. Your tech should contact us directly at the number in my signature below.

If you replaced the buttons then I would check that no debris found its way into the port that it plugs into on the Interface. If there is none then the Interface probably needs servicing.

This model of the 9500ic has both English and Spanish languages which was properly identified by Detector Tools.
__________________

Escort Radar customer service is available from 8am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #12  
Old April 20th, 2017
MiAMG MiAMG is offline
Junior Member
 
Join Date: Apr 2017
Posts: 8
Default

Quote:
Originally Posted by EscortRadar View Post
There's nothing evident from your description or from the pictures as to why the buttons are not responding. Your tech should contact us directly at the number in my signature below.

If you replaced the buttons then I would check that no debris found its way into the port that it plugs into on the Interface. If there is none then the Interface probably needs servicing.

This model of the 9500ic has both English and Spanish languages which was properly identified by Detector Tools.
Update...Spoke with Doug from customer service. My control module does not even light up, so Doug said to send the entire interface in. I shipped it out yesterday to you guys. RMA #R00000653651. Ill be waiting to hear back!
Reply With Quote
  #13  
Old April 22nd, 2017
Butcher318 Butcher318 is offline
Senior Member
 
Join Date: Dec 2011
Location: Indiana
Posts: 1,577
Default

Maybe I don't understand how these systems are sold or installed. If I had that kind of problem and the system is under warranty the dealer where I purchased it and had it installed would be dealing with it. I drop the car off and say fix it, they trouble shoot it, call Escort, and they ship it back. Not me.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:14 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2012 Escort Inc.