Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > Passport 9500ci

Notices

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old August 1st, 2018
pcleve pcleve is offline
Junior Member
 
Join Date: Aug 2018
Posts: 2
Question Please Help: 9500ci errors

Hey all, I have been happily running my 9500ci for a few years now an just today I started getting a persistent "Check Receiver Wiring" error. I am about to go on a 3,000 mile road trip this Friday and am trying to rapidly fix this problem.

The current issue: My device powers on normally and shows the icon for GPS searching and the status of the radar for about 10-15 seconds then every time it returns back to the "Check Receiver Wiring"

I have done some research and tried messing with my device. All the wires are properly plugged into the hub with no recent changes to my car. I tried messing with the RJ plugs and everything is making contact and I don't see any issues.

I read here on the form that some people have been able to reset the device and that fixed their issue sometimes, if I don't make any progress I plan to try that out tonight.

Can anyone who has had issues like this please help me??
Thanks in advance!
Reply With Quote
 

Tags
9500ci, check receiver wiring, error, wiring error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:49 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.