Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360c

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #81  
Old 1 Week Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,780
Default

Quote:
Originally Posted by rottikid View Post
PLEASE HELP. MAX 360C NOT SHOWING PSL. IN THE RARE INSTANCE IT DOES IT IS WRONG. THIS IS MY SECOND DETECTOR. WHAT MAKES MATTERS WORSE SOMETIMES THE PSL WILL SHOW 40mph in the PSL ACTUAL SPEED LIMIT IS 55mph I HAVE THE OVER SPEED LIMIT SET FOR 70mph and the detector will turn red and give warning, which it should and is correct for 15 MPH over speed limit,.

When spending this kin=d of money for a detector I expect it to work withoput any [problems at all. PLEASE HELP WHEN WILL THIS BE FIXED OR SHOULD I RETURN THE DETECTOR.
We do not currently have speed limits for every road, only major roads. We are looking into improving this and the coverage.

Speed limits not showing for roads that you have seen the speed limit for before is typically due to GPS or cell phone reception issues.

If it continues let us know.

Quote:
Originally Posted by flg View Post
You are assuming that they couldn't replicate the issue, but I don't know if that is a fact, as they never followed up through…

With so many users reporting this issue for so long, they must surely know what is causing this by now, most likely the solution implies a monetary cost that they are not willing to assume.
We are certainly following up on these reports. If yours was missed, I apologize.

Some were due to the user not registering the detector. Others were due to server issues we had several months ago.

With a few, like rmreid10, we have not been able to reproduce what they are seeing yet. We continue to work with them and will have it resolved ASAP.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #82  
Old 1 Week Ago
flg flg is offline
Junior Member
 
Join Date: Feb 2019
Posts: 16
Default

Quote:
Originally Posted by Butcher318 View Post
Your original post was not "deleted" as you claimed, it was moved to the appropriate section of the forum. If it was deleted it would be gone.
I did delete my original post in this topic/thread and re-posted in the appropriate topic. It happens that it was quoted before my deletion happened. Users cannot move posts.
Reply With Quote
  #83  
Old 4 Days Ago
rmreid10 rmreid10 is offline
Senior Member
 
Join Date: Jul 2010
Location: TN
Posts: 195
Question

Quote:
Originally Posted by rmreid10 View Post
I was specifically talking about my 360c that I returned and I was told that they could not replicate the issue and that PSL worked fine
New MAX360c unit and PSL still does not work but downloaded a FW update and a DB update without issue
HELP
Reply With Quote
  #84  
Old 4 Days Ago
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 347
Default

Quote:
Originally Posted by rmreid10 View Post
New MAX360c unit and PSL still does not work but downloaded a FW update and a DB update without issue
HELP
It is very possible it might be a server issue in your area. I would call in to Escort and ask about this.....
__________________
I use the following Escort Products

Escort Redline EX
Max360c with wifi
M1 Dash cam with both detectors
Escort Live
ZR5 Shifters
------------------------------------------------------------
Reply With Quote
  #85  
Old 4 Days Ago
rmreid10 rmreid10 is offline
Senior Member
 
Join Date: Jul 2010
Location: TN
Posts: 195
Default

Quote:
Originally Posted by Esc0rtFan View Post
It is very possible it might be a server issue in your area. I would call in to Escort and ask about this.....
Escort is aware of my issue
Reply With Quote
  #86  
Old 3 Days Ago
rmreid10 rmreid10 is offline
Senior Member
 
Join Date: Jul 2010
Location: TN
Posts: 195
Unhappy

Quote:
Originally Posted by rmreid10 View Post
New MAX360c unit and PSL still does not work but downloaded a FW update and a DB update without issue
HELP
I am still needing HELP!!
Reply With Quote
  #87  
Old 2 Days Ago
rmreid10 rmreid10 is offline
Senior Member
 
Join Date: Jul 2010
Location: TN
Posts: 195
Exclamation

Quote:
Originally Posted by rmreid10 View Post
I am still needing HELP!!
Waving hands, I still need HELP

Reply With Quote
  #88  
Old 2 Days Ago
flg flg is offline
Junior Member
 
Join Date: Feb 2019
Posts: 16
Default

Quote:
Originally Posted by rmreid10 View Post
Waving hands, I still need HELP

They apparently don't have a solution for many of us with the no PSL issue, in my case it's no PSL when connected via Wi-Fi: http://escortradarforum.com/forums/s...&postcount=120

I initially obtained a response from Escort Support, but even after I provided all the requested info, as I said before, they don't follow through, extremely frustrating.

Last edited by flg; 2 Days Ago at 11:47 PM. Reason: spelling
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:35 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.