Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 9500ix, S75G

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old August 13th, 2014
Mack Mack is offline
Junior Member
 
Join Date: Aug 2014
Posts: 2
Default Replacement Speaker - Ebay = $8.50

The speaker on my 2010 9500ix first became increasingly unintelligible, then ceased working altogether.

Following the suggestions from another poster, I removed the three (3) Phillips head screws from the bottom that hold the top and bottom of the detector together, as well as keeping the dark opaque front piece in place.

The speaker is readily accessible, and the white electrical connector to the circuit board is simple to disconnect.

I then ordered a new speaker from an entity that advertised on Ebay. Upon receipt, I carefully extracted the rubber from around the defective speaker and inserted the new speaker in its place; then, inserted the white electrical connector into the slot on the circuit board.

Voila, it works like new.

The Ebay listing for a new speaker can be found here: Link removed by Moderator

Mack

Moderator comment: Please to not link to third-party products on the forum. Thank you for your cooperation.

Last edited by TBNTX; August 13th, 2014 at 02:11 PM. Reason: Removed Link.
Reply With Quote
  #2  
Old August 13th, 2014
BelsCortFan's Avatar
BelsCortFan BelsCortFan is offline
Senior Member
 
Join Date: Nov 2011
Location: IN the Back of your Mind
Posts: 1,649
Default

Quote:
Originally Posted by Mack View Post
The speaker on my 2010 9500ix first became increasingly unintelligible, then ceased working altogether.

Following the suggestions from another poster, I removed the three (3) Phillips head screws from the bottom that hold the top and bottom of the detector together, as well as keeping the dark opaque front piece in place.

The speaker is readily accessible, and the white electrical connector to the circuit board is simple to disconnect.

I then ordered a new speaker from an entity that advertised on Ebay. Upon receipt, I carefully extracted the rubber from around the defective speaker and inserted the new speaker in its place; then, inserted the white electrical connector into the slot on the circuit board.

Voila, it works like new.

The Ebay listing for a new speaker can be found here: Link removed by Moderator

Mack


Moderator comment: Please to not link to third-party products on the forum. Thank you for your cooperation.
Thanks Mack, I have done the same for my Redline and the SC55. Seems like
speakers are a continuing issue with many units.
Reply With Quote
  #3  
Old August 20th, 2014
Mack Mack is offline
Junior Member
 
Join Date: Aug 2014
Posts: 2
Thumbs up

Quote:
Originally Posted by BelsCortFan View Post
Thanks Mack, I have done the same for my Redline and the SC55. Seems like speakers are a continuing issue with many units.
You are welcome.

Being as the "moderator" removed the link I posted to the new 9500ix speaker replacement I purchased from Ebay, be advised that I found it by logging into Ebay, then conducting a search using "Escort 9500ix Speaker" --- but without the quotation marks.

The rubber speaker holder is simple to lift out, and replace the old broken speaker with the new speaker. The replacement in the rubber holder slips back into place as easily as it was removed.

I'm attaching a picture of the replacement speaker I purchased from Ebay.

Enjoy,

Mack
Attached Images
 
Reply With Quote
  #4  
Old August 20th, 2014
Krazy-K's Avatar
Krazy-K Krazy-K is offline
Senior Member
 
Join Date: Apr 2013
Location: Down North
Posts: 1,169
Default

Good job Mack!

Thanks
Reply With Quote
  #5  
Old November 11th, 2014
T_House T_House is offline
Junior Member
 
Join Date: Nov 2014
Posts: 1
Default

I wish I would have read this thread before I did what I did. I just sent my detector in last week and paid the $140 for the premium service as the sound on mine stopped working, a little at a time at first, then all together. I figured it was more than just the speaker though as I used the headphone jack and a external speaker for about 2 weeks and then that stopped working as well. To me, that seemed like more than just a speaker issue. Oh well, regardless I am set to get mine back from service tomorrow. I hate driving without it.
Reply With Quote
  #6  
Old November 12th, 2014
GIG4FUN's Avatar
GIG4FUN GIG4FUN is offline
Senior Member
 
Join Date: Oct 2011
Posts: 625
Default

Quote:
Originally Posted by Mack View Post
The speaker on my 2010 9500ix first became increasingly unintelligible, then ceased working altogether.

Following the suggestions from another poster, I removed the three (3) Phillips head screws from the bottom that hold the top and bottom of the detector together, as well as keeping the dark opaque front piece in place.

The speaker is readily accessible, and the white electrical connector to the circuit board is simple to disconnect.

I then ordered a new speaker from an entity that advertised on Ebay. Upon receipt, I carefully extracted the rubber from around the defective speaker and inserted the new speaker in its place; then, inserted the white electrical connector into the slot on the circuit board.

Voila, it works like new.

The Ebay listing for a new speaker can be found here: Link removed by Moderator

Mack

Moderator comment: Please to not link to third-party products on the forum. Thank you for your cooperation.
only $6.75 shipped for mine... I'll put up for a spare when needed.
he has lots of bletronics stuff too.

just search the bay, it's easy enough

win win here.

thank you Mack
__________________

* *
10/20/15, latest new one! a MAX360
* *
RedLine ----->(for Highway) (new 9/2013)
MAX (I use for "city" )(new 7/2013)
9500ix (new 10/2012)
8500X50 (new 8/2009)
(2) Escort Live - Smart cord & Hard install
GoPro3 Hero Black edition
H&K LEM 45c C1
SHOTshow attendee & NRA
Reply With Quote
  #7  
Old November 16th, 2014
GIG4FUN's Avatar
GIG4FUN GIG4FUN is offline
Senior Member
 
Join Date: Oct 2011
Posts: 625
Default

Quote:
Originally Posted by GIG4FUN View Post
only $6.75 shipped for mine... I'll put up for a spare when needed.
he has lots of bletronics stuff too.

just search the bay, it's easy enough

win win here.

thank you Mack
I got it yesterday and wow, it is smaller than I thought... well, I am a musician and am used to BIG speakers. LOL

nice find and thank you.
__________________

* *
10/20/15, latest new one! a MAX360
* *
RedLine ----->(for Highway) (new 9/2013)
MAX (I use for "city" )(new 7/2013)
9500ix (new 10/2012)
8500X50 (new 8/2009)
(2) Escort Live - Smart cord & Hard install
GoPro3 Hero Black edition
H&K LEM 45c C1
SHOTshow attendee & NRA
Reply With Quote
  #8  
Old November 24th, 2014
Butcher318 Butcher318 is offline
Armchair Expert
 
Join Date: Dec 2011
Location: Indiana
Posts: 2,035
Default

Quote:
Originally Posted by T_House View Post
I wish I would have read this thread before I did what I did. I just sent my detector in last week and paid the $140 for the premium service as the sound on mine stopped working, a little at a time at first, then all together. I figured it was more than just the speaker though as I used the headphone jack and a external speaker for about 2 weeks and then that stopped working as well. To me, that seemed like more than just a speaker issue. Oh well, regardless I am set to get mine back from service tomorrow. I hate driving without it.
True but you got a lot more for the 140 bucks then a speaker repair.
Reply With Quote
Reply

Tags
9500ix, ebay, replace, replacement, speaker

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:53 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.