Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > ZW5 and ZR5

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old June 3rd, 2018
David H David H is offline
Junior Member
 
Join Date: Jun 2018
Posts: 10
Default ZW5 installed, a few questions.

1. I did the self install of my ZW5 paired with my max 360c. Is there any benefit of using a direct connection to the car battery (per install instructions), rather than tapping into my fuse box?

2. Is there any way to know that the ZW5 is communicating to the detector short of getting shot by laser or using a laser jammer tester? When I turn on the radar it does not" acknowledge" or cycle through the shifters like my 9500ci did.

3. On occasion, I get a one second "laser shifting shift" on the radar detector display, (with no voice alert), then resumes to "auto " mode setting. This is NOT associated with acceleration and there are no apparent sources of a falsing. Is there always a voice alert when the shifters are actually shifting? If so, what is causing this.

Thanks in advance.
Reply With Quote
  #2  
Old June 5th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,048
Default

Quote:
Originally Posted by David H View Post
1. I did the self install of my ZW5 paired with my max 360c. Is there any benefit of using a direct connection to the car battery (per install instructions), rather than tapping into my fuse box?
Yes. Many modern vehicles only supply enough power to their circuits to operate the vehicle's functions. Even if the detector/ZW5 powers on from a fuse box connection, they may lose power when there is a larger drain on them, such as during an alert and while shifting.
Quote:
Originally Posted by David H View Post
2. Is there any way to know that the ZW5 is communicating to the detector short of getting shot by laser or using a laser jammer tester? When I turn on the radar it does not" acknowledge" or cycle through the shifters like my 9500ci did.
3. On occasion, I get a one second "laser shifting shift" on the radar detector display, (with no voice alert), then resumes to "auto " mode setting. This is NOT associated with acceleration and there are no apparent sources of a falsing. Is there always a voice alert when the shifters are actually shifting? If so, what is causing this.
This is confirmation that the ZW5 is communicating to your detector.

From pg5 of the manual: To confirm communication with ZW5, the detector will display Laser Shifters Shift on power up.

It can take a few seconds after power-up for this to be displayed. If you are not seeing this message then check the ZW5's "under-the-hood" interface + and - 12V connections, make sure that the interface is near the top of your engine compartment (not buried down by the engine), and that the "this side up" arrow is pointing up.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #3  
Old June 5th, 2018
David H David H is offline
Junior Member
 
Join Date: Jun 2018
Posts: 10
Default Still with connectivity problems.

Thanks for your quick reply.

I checked my battery connections-solid.

Interface is up high in the engine bay and facing upward as directed.

Does the exact location the interface matter? Closer to windshield?

Having intermittent connectivity issues-sometimes pairs with radar detector at start up, others times does not pair.

Not sure if something is interfering.

Anyhow, will take to local Escort dealer to look at my installation.
Reply With Quote
  #4  
Old June 7th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,048
Default

Try moving the interface closer to the windshield.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #5  
Old June 18th, 2018
David H David H is offline
Junior Member
 
Join Date: Jun 2018
Posts: 10
Default Update on my ZW5 Issues

Took my unit to the local authorized Escort dealer. They confirmed that my installation was correct and they could not get the laser shifters to communicate with my Max360c.

They spoke to Escort tech support and were told that there are reported issues with some of these units in terms of connectivity.

Escort graciously agreed to accept my return for a full refund.

I will consider purchasing the ZR5 instead.
Reply With Quote
  #6  
Old June 18th, 2018
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,459
Default

Appreciate the update.
Reply With Quote
  #7  
Old June 27th, 2018
David H David H is offline
Junior Member
 
Join Date: Jun 2018
Posts: 10
Default

Escort,

Is it worth trying another unit. It was not explained whether the unit that I purchased was defective or whether there was a specific issue with the unit and my vehicle.

I was told by my installer that there have been issues with 6 units to date.

I still like the idea of portability with the ZW5.

Thanks
Reply With Quote
  #8  
Old June 27th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,048
Default

Yes it is worth trying another ZW5. There may have been an issue with that one. We have since put measures in place to prevent any more with communication issues from shipping.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #9  
Old 4 Weeks Ago
David H David H is offline
Junior Member
 
Join Date: Jun 2018
Posts: 10
Default

Escort,

Among the units returned to you, including mine, can you explain why the connectivity issues occurred and is this no longer an issue being reported?

Thank you.
Reply With Quote
  #10  
Old 4 Weeks Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,048
Default

I am not aware of this being reported any longer. We have not had any further reports here on the forum.

A connectivity test was being done but it did not take certain factors into account which may impact some installations. We have since changed this test to take these factors into account with great results.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:19 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.