Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old July 1st, 2018
DPJ DPJ is offline
Junior Member
 
Join Date: Jun 2018
Posts: 3
Default issue since 2016.

Hello again,

I see on the forums that this Bluetooth icon issue has been going on for years.

This is from a moderator back in 2016:
There have been reports of some seeing the bluetooth icon on the detector with no speed limit sign. If you see this then try to update the detector and it fails the update then there is a problem with the detector.

-----------------------------------------------------------------

So, does the item have to be inspected or is this an ongoing unsolvable issue?
Reply With Quote
  #12  
Old July 2nd, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,170
Default

This issue has not gone on non-stop since then. Certain Android phones and Android OS versions have had issues with Escort Live while others work better.

You can try to un-pair and pair your Max 360 again.

Android has recently released OS updates which solves bluetooth connection issues. The next version of Escort Live will also have a new pairing mechanism which should resolve many bluetooth connection issues. I don't have an ETA for the update.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #13  
Old July 4th, 2018
GumbyDammit223 GumbyDammit223 is offline
Senior Member
 
Join Date: Dec 2016
Posts: 122
Default

It's the first time in months I've actually driven more than a couple miles at a time and have been able to actually use EL. The phone is a Samsung Edge 7 running standard Verizon Oreo. In order for the M360 to display speed limits or receive any sort of information from EL, EL MUST remain open at all times on the phone. If you bring up the home screen, EL goes dormant and is useless. Locking your phone shuts it down as well. I just finished driving a 360+ mile loop and my fully charged battery at the start was completely drained by having EL active the entire time.

I really hope a firmware update will be forthcoming because Oreo blows goats and has rendered numerous things on the phone worthless with EL being one of them.
Reply With Quote
  #14  
Old July 6th, 2018
Stinger22 Stinger22 is offline
Junior Member
 
Join Date: Mar 2017
Posts: 16
Default

I'm on a Samsung S8 with latest updates and quite often with the 360 connected via BT still only get the blue BT symbol instead of the PSL even though EL is showing it on the phone. And still occasional "cannot connect to gps services" even though other apps are using gps services.

I have to stop the app and back on or restart the detector to get it to display.

The strange one is sometimes when the 360 is running and I turn on EL and nothing so I touch the BT symbol for the app and it says the "radar detector is not intialized" even though it is operating just fine. I have to restart the detector.
Reply With Quote
  #15  
Old July 7th, 2018
GumbyDammit223 GumbyDammit223 is offline
Senior Member
 
Join Date: Dec 2016
Posts: 122
Default

Here are a couple threads talking about Oreo (Android 8) and EL:

http://www.escortradarforum.com/foru...ad.php?t=17728

http://www.escortradarforum.com/foru...ad.php?t=17796

In essence, Oreo screwed us w.r.t. Bluetooth connectivity and Escort needs to find a workaround.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:33 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.