Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 9500ix, S75G

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 1 Week Ago
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,278
Default

Quote:
Originally Posted by quakeman3 View Post
Hmmmm...
don't know what's wrong but I cant get the gps signal indicator light to stop blinking.

I tried moving the detector outside my vehicle to get a signal, but no luck.
Also tried a factory reset...no luck
If you are in an area with tall structures or terrain, try somewhere else. Give it at least 5 minutes for initial acquisition just to be sure. If you have a Garmin GPS see if it can acquire satellites in your car. Otherwise sounds like you need to contact ESCORT for repair or a trade-in.
Reply With Quote
  #12  
Old 1 Week Ago
TBNTX's Avatar
TBNTX TBNTX is online now
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 5,821
Default

Quote:
Originally Posted by quakeman3 View Post
Hmmmm...
don't know what's wrong but I cant get the gps signal indicator light to stop blinking.

I tried moving the detector outside my vehicle to get a signal, but no luck.
Also tried a factory reset...no luck
Chances are that your vehicle has an athermic windshield that contains metal, or the windshield may have had some after-market tinting that contains metal. If so, it's blocking the GPS signal.

What is the make, year and model of your vehicle?

If you don't have an athermic windshield (or tinting that contains metal), the next question is where are you mounting the detector? Ideally, it should be dead center on the windshield, so that the GPS chip has a full view of the sky above.
__________________


Countermeasures:

Radar Detectors: Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)
Reply With Quote
  #13  
Old 1 Week Ago
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,278
Default

Quote:
Originally Posted by quakeman3 View Post
* * *
My friend has the same detector and he has never downloaded anything but his 9500ix recognizes everything.
Per your note above and TBNTX's comments, why don't you try plugging your RD in your friend's car and visa versa to see if they get GPS lock.
Reply With Quote
  #14  
Old 1 Week Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 14,905
Default

It will take about one minute for it to acquire GPS the first time after it has moved while powered off, or if it has been powered off for several days.

If the detector has not acquired GPS after one minute without moving, then there is an issue with the detector.


Note that if your vehicle has a metallic coated anti-radiation windshield then this will block the GPS signal. You should be able to slightly see this coating, and there may be areas on the windshield which do not have this coating.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:37 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright © 2017 Escort Inc.