Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > Passport 9500ci

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old October 13th, 2015
CJR238's Avatar
CJR238 CJR238 is offline
Senior Member
 
Join Date: May 2009
Location: CT
Posts: 4,244
Default

Quote:
Originally Posted by NYC_Phil View Post
Thank you Nine. I am installing now and this helps a lot. I see you have one laser shifter in the rear. SOme have suggested that I need 2 in the rear. I guess you voted by what you did but do you know if most people go with 1 or 2?

Thanks so much your review helps a lot!

phil

lol Nine doesn't use jammers, and this was my install. lol

Yes, its best to run 2 heads for the rear for good protection, especially if you see rear shots.

The 1 rear head is a ZR4 which was the only option at the time of this post.
__________________
To embrace technology is not to blindly accept it. We must always question and test technology but never be afraid to use it.


Max, RedLine, 9500ci, 9500ix, 9500I x2, 8500, X50 Black, PRO300, SmartRadar, V1, Passport.

My 9500I/ix review and TrueLock info:
http://escortradarforum.com/forums/showthread.php?t=96

My install:
http://www.rdforum.org/showthread.php?t=37598

http://escortradarforum.com/forums/s...1131#post11131
Reply With Quote
  #12  
Old November 5th, 2015
LobsterMan LobsterMan is offline
Junior Member
 
Join Date: Nov 2015
Posts: 1
Default Dont puchase 9500ci

I purchased a new car and had them install the 9500 ci. After many false alarms and system going off randomly I returned for updates. Once again the same thing happened. They replaced with a new system and the same thing keeps happening. It continues to go off randomly, marks randomly and is a poor product for the amount paid. I also own several other Escort products and have no complaints. Buyer beware on this one.
Reply With Quote
  #13  
Old November 8th, 2015
CJR238's Avatar
CJR238 CJR238 is offline
Senior Member
 
Join Date: May 2009
Location: CT
Posts: 4,244
Default

Quote:
Originally Posted by LobsterMan View Post
I purchased a new car and had them install the 9500 ci. After many false alarms and system going off randomly I returned for updates. Once again the same thing happened. They replaced with a new system and the same thing keeps happening. It continues to go off randomly, marks randomly and is a poor product for the amount paid. I also own several other Escort products and have no complaints. Buyer beware on this one.
The CI can get updates via USB so Escort wouldn't take it as a "return for updates".

Who installed the unit? The issues sound more like the install than the unit.

Almost sounds like you never had a CI.

Sent from my XT1080 using Tapatalk
__________________
To embrace technology is not to blindly accept it. We must always question and test technology but never be afraid to use it.


Max, RedLine, 9500ci, 9500ix, 9500I x2, 8500, X50 Black, PRO300, SmartRadar, V1, Passport.

My 9500I/ix review and TrueLock info:
http://escortradarforum.com/forums/showthread.php?t=96

My install:
http://www.rdforum.org/showthread.php?t=37598

http://escortradarforum.com/forums/s...1131#post11131
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:16 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.