Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 9500ix, S75G

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 29th, 2018
jmcalabria jmcalabria is offline
Junior Member
 
Join Date: Jan 2011
Posts: 1
Default Repeating Voice Messages

One of my 9500ix units has started doing something I have not seen reported here. It constantly repeats certain voice messages. In operation, every alert starts a neverending "Mark Location?" prompt that only power cycling will stop. During preference setup, it prompts normally until you get to the Bands section, then it begins to incessantly repeat the "Bands" voice prompt which, again, can only be stopped by power cycling. I have reset the unit from the local controls as well as via detector tools. From detector tools all appears/operates normally (including Bands setup).

Anything I can do to reset this glitch or do I need to send it in?
Reply With Quote
  #2  
Old July 30th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,383
Default

It will need to be sent in for servicing. To set this up, please contact our customer service department at the number in my signature below.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:24 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.