Escort Radar Forum  

Go Back   Escort Radar Forum > Escort Live! > Escort Live! for Android

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 5th, 2018
ScottMN ScottMN is offline
Junior Member
 
Join Date: Jul 2018
Posts: 4
Default Android Oreo, Escort Live, and Background GPS not working

I'm using a Max360 with Escort Live running on a Samsung S7. Everything worked well with little to no complaints. Launch the app, connects via bluetooth, GPS locks, speed limits and actual speed in MPH shown on the detector both with the app running in the foreground and the screen off with the app in the background.

Recently I was pushed the Oreo update (8.0.0). Escort Live works when the app is in the foreground. But when it's in the background with the screen off, the posted speed limits no longer update. Plus when I unlock the screen I need to recenter Escort Live and the blue dot comes back into view.

Doing a little research it looks like Oreo is now enforcing background location limits to a few times per hour. The suggested solution is for the app to create a foreground service with an ongoing notification in the notification area. Perhaps the Escort Live app v2.1.9.4 needs an update to work properly with Oreo? See here: https://developer.android.com/about/...ocation-limits

A possible temporary workaround for power users is to whitelist v2.1.9.4 using developer tools. Turn on USB debugging on your phone. Connect the phone via USB and enable the connection. Use the developer tool ADB.EXE and start a shell. Then issue the magic commands to whitelist "com.escort.androidui.root". Details here: https://www.xda-developers.com/andro...ion-whitelist/ Details on installing ADB.EXE here: https://www.xda-developers.com/insta...s-macos-linux/

I will be testing this workaround on the way home from work later today.
Reply With Quote
  #2  
Old July 5th, 2018
ScottMN ScottMN is offline
Junior Member
 
Join Date: Jul 2018
Posts: 4
Default

Success! With the phone on the lock screen and the Escort Live app in the background I'm now getting updates to the speed limit and seeing live alerts on the detector. Whitelisting the app as a workaround on Oreo is a temporary solution.

Escort - the ball is in your court now to fix the Escort Live app to properly support Android Oreo/8.x. Running the app in the background is broken. Or send me the source code and I'll fix it, for a fee of course
Reply With Quote
  #3  
Old August 8th, 2018
kovach kovach is offline
Member
 
Join Date: Aug 2009
Posts: 51
Default

I've found on my S8 Active if you go into Device Maintenance->Battery and set the Power Saving Mode to Off, it also continues to work.

Somewhat annoying having to do that whenever you want to use the BT hookup but it works for me.
Reply With Quote
  #4  
Old August 9th, 2018
GumbyDammit223 GumbyDammit223 is offline
Senior Member
 
Join Date: Dec 2016
Posts: 123
Default

On my Edge 7 I already have power savings turned off and am always running in Performance Mode. Still No Joy For Me.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:46 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.