Escort Radar Forum  

Go Back   Escort Radar Forum > Detector Accessories > Power Cords

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old August 3rd, 2018
kanwisch kanwisch is offline
Junior Member
 
Join Date: Aug 2018
Posts: 2
Default Direct line and smart cord testing help

Something odd happened to my direct wire that feeds a non-Live version of detector (9500IX IIRC). The fuse for the cig connection is fine, the fuse in the direct wire is fine, yet the detector does not turn on. I looked at the PCB in the mute housing and there are no signs of burnout. Is there a good way to test the 4-wire connection? Should it pass power and ground past the mute housing even if not plugged into the detector? Just not sure how to electrically test this thing to figure out what might be the problem.

I am having the exact same problem with one of my coiled smart cords that came with the detector, so I'll use the troubleshoot advice on it too.

I know the detector works because I have yet another coiled smart cord into which the detector and the same cig connection mentioned above.
Reply With Quote
  #2  
Old August 6th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,321
Default

You mentioned that the detector does not power on with another cord. Does it power on with any power cord? Typically there is an issue with the detector when this happens.

To set up servicing your detector and cord, please call us at the number in my signature below.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #3  
Old August 6th, 2018
kanwisch kanwisch is offline
Junior Member
 
Join Date: Aug 2018
Posts: 2
Default

I have two, coiled Smart cords. One works with the detector, one does not. Same cig outlet in the car.

Basic question: How can I measure whether this is the PCB or something else in that Smart cord?
Reply With Quote
  #4  
Old August 7th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,321
Default

I do not have that information available. There is an SMT fuse on the board which may have blown. Something caused it to blow so there may be an issue with the detector.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:18 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.