Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > Passport SRX, SR7

Notices

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 12th, 2011
m3freak86
Guest
 
Posts: n/a
Default Delete

Delete

Last edited by m3freak86; August 16th, 2012 at 11:27 PM.
  #2  
Old July 12th, 2011
CJR238's Avatar
CJR238 CJR238 is offline
Senior Member
 
Join Date: May 2009
Location: CT
Posts: 4,244
Default

Well it sounds like your radar antenna needs service, which should be in the front of the vehicle.
__________________
To embrace technology is not to blindly accept it. We must always question and test technology but never be afraid to use it.


Max, RedLine, 9500ci, 9500ix, 9500I x2, 8500, X50 Black, PRO300, SmartRadar, V1, Passport.

My 9500I/ix review and TrueLock info:
http://escortradarforum.com/forums/showthread.php?t=96

My install:
http://www.rdforum.org/showthread.php?t=37598

http://escortradarforum.com/forums/s...1131#post11131
  #3  
Old July 12th, 2011
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 15,791
Default

It was a coincidence. The self cal message is because the radar receiver is out of calibration and is trying to calibrate. You can try resetting the system to see if that helps. Turn the system off, hold down the city and mute buttons and power it on. You should see a "reset" message.

If the self cal message persists then it cannot calibrate and you will probably soon see a service required message. The radar receiver will have to be serviced if this is the case. I have no idea where it was installed but it has to be in front of the vehicle somewhere. Possibly behind a bumper cover.

You can find all of our manuals here including the SR7 manual and it's installation manual.

Good luck, let us know if you need any further help.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
  #4  
Old July 13th, 2011
CJR238's Avatar
CJR238 CJR238 is offline
Senior Member
 
Join Date: May 2009
Location: CT
Posts: 4,244
Default

Quote:
Originally Posted by m3freak86 View Post
Do you think it's just a coincidence then? Or do you think since I cut the wire, it caused the issue. How do I go about taking the front radar antenna out?
Definitely a coincidence. Follow the cable from the antenna to the box. I'm not sure if the antenna cable has a removable coupler so you don't need to unplug from the CPU like the 9500CI.
__________________
To embrace technology is not to blindly accept it. We must always question and test technology but never be afraid to use it.


Max, RedLine, 9500ci, 9500ix, 9500I x2, 8500, X50 Black, PRO300, SmartRadar, V1, Passport.

My 9500I/ix review and TrueLock info:
http://escortradarforum.com/forums/showthread.php?t=96

My install:
http://www.rdforum.org/showthread.php?t=37598

http://escortradarforum.com/forums/s...1131#post11131
  #5  
Old July 13th, 2011
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 15,791
Default

There should be a connector in between the interface module so you don't have to re-route it through the firewall if you need to disconnect the receiver. There may be heat shrink tubing on the connector which you will need to cut off to detach the connector.

The interface module (where every module connects) is typically mounted under the dash.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
  #6  
Old August 16th, 2012
radarrob's Avatar
radarrob radarrob is offline
Senior Member
 
Join Date: Mar 2010
Location: Speed Trap
Posts: 110
Default

Try a factory reset.
__________________
Need your radardetector or countermeasure installed/tested? Pm me for details.



It just comes with experience"
  #7  
Old October 7th, 2012
harder99 harder99 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 14
Default

Quote:
Originally Posted by m3freak86 View Post
Delete
Just had body work performed on my right fender, feet away from the antenna and laser units, and now I have the Self Calibration running every 15 seconds. Found a Cal3 Error somehow. Any thoughts? Thank you
  #8  
Old October 8th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 15,791
Default

The radar receiver module will need to be serviced. Please call us at the number in my signature below to set this up.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
  #9  
Old October 19th, 2012
harder99 harder99 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 14
Default Thank you!

Wow. Mailed last Friday for the repair and received it today - already installed it. What a bargain and what quick service - thank you. In addition to calibration, the plastic housing was replaced and so was the cable. Excellent customer service. I've owned Escort products since the fist Escort and i also own two 9500ci's - installed in my other two cars. Will continue to be a customer in the future.
  #10  
Old October 19th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 15,791
Default

Delivering the best customer service is very important to us. Thank you so much for following up and reporting your experience with our service department. Have a great weekend!
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:06 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.