Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > Passport SRX, SR7

Notices

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old February 6th, 2011
grgmini grgmini is offline
Junior Member
 
Join Date: Feb 2011
Posts: 1
Default SRX Receiver Wiring Error

Hi, I have an SRX that I bought used with a receiver wiring error. This past summer, I sent the receiver in to be repaired while waiting for my car to come out of the body shop. I bench tested the system when it came back and the error was gone. I finally have the car back and I spent the day(and night) installing the unit. Upon powering up for the first time in the car, I have the dreaded "Check Receiver Wiring" error again. I have checked the entire length of wiring and do not see any obvious sign of damage, no chaffing, kinking, etc.
I will call customer service on Monday, but in the mean time, my car is torn apart. I suppose I don't really have a question, just venting after 15 hours of fabricating brackets, cutting bumpers and notching grills and its 4:30 in the morning. I just expected it to work.
--Dan
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:10 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.