Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > Passport SRX, SR7

Notices

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old December 8th, 2015
Rocad Rocad is offline
Junior Member
 
Join Date: Dec 2015
Posts: 2
Default Passport SRX problem

Hi,

I have had my SRX installed for many years now. It was installed by the dealer.

Problem I'm having now is that as soon as I turn it on, I get a constant tone coming out of the unit.

Any ideas?

Is there a "reset" button I can try?
  #2  
Old December 8th, 2015
buckdharma's Avatar
buckdharma buckdharma is offline
Senior Member
 
Join Date: Dec 2010
Location: Chicago Area
Posts: 1,903
Default

Try holding down City and Mute buttons and power up while holding those buttons down. That is the reset procedure for the SRX, its worth a try.



Quote:
Originally Posted by Rocad View Post
Hi,

I have had my SRX installed for many years now. It was installed by the dealer.

Problem I'm having now is that as soon as I turn it on, I get a constant tone coming out of the unit.

Any ideas?

Is there a "reset" button I can try?
__________________
Radio Shack, Fuzzbuster, FuzzbusterII, Original Escort, Original Passport, Passport 3200 Wideband, Passport 1000 add on Laser Detector, GT2 G Timer,8500, 8500X50, 9500i, 9500ix, IQ, Redline BS/RDR with SC55, Max, Max 360, LIVE, Radenso Pro SE, and Veil.
  #3  
Old December 8th, 2015
Rocad Rocad is offline
Junior Member
 
Join Date: Dec 2015
Posts: 2
Default

PERFECT!

That seems to have worked....thanks MUCH.

I've been living with this issue for awhile.
  #4  
Old January 20th, 2016
lagunacomputer lagunacomputer is offline
Junior Member
 
Join Date: Jan 2016
Posts: 1
Default SRX saved me from laser hit today

my SRX saved me from a clean straight on laser hit today at about <=1/4 mile today. I have the twin front sensors up front + 1 rear on my toyota tundra .

Jammer went ballistic, Islammed on the brakes, motorcycle officer looked up at me a little bewildered, then he pulled out and lit up the guy who went screaming past me in the other lane lol

i bought it new in the box on craigslist for $75 about 3 months ago. Thing works great! I just turned off x and K band, as the newer car rear sensors seem to be running on K band and it was annoying.
Every real threat around me is Ka or Laser anyways, so it's actually way helpful in cutting out false alerts.

so california
Attached Images
 

Last edited by lagunacomputer; January 20th, 2016 at 09:11 PM.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:23 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.