Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > ESCORT iX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 26th, 2019
gman1205 gman1205 is offline
Junior Member
 
Join Date: Jul 2019
Posts: 1
Default Escort iX display went dark

The display on my Escort iX will no longer come on. The unit seems to still be working other than that. I had not made any changes to it prior. I tried to change the brightness settings but that did not help
Reply With Quote
  #2  
Old July 28th, 2019
Bigwill41's Avatar
Bigwill41 Bigwill41 is offline
Senior Member
 
Join Date: Oct 2009
Location: Navasota, Texas
Posts: 498
Send a message via AIM to Bigwill41 Send a message via MSN to Bigwill41
Default

Maybe check your brightness level


Sent from my SM-N960U using Tapatalk
__________________
Escort Redline
Escort 9500I
Escort 9500IX
Escort 8500 X50 Blue
Escort Passport SC55
Beltronics STi Driver
Valentine One 3.872
Whistler Pro-78SE (Where is the filter on this thing)

My Channel http://www.youtube.com/user/Wellmann41


K-Band Radar Unit:
*Knock Knock...*
9500ci: *Who's there?*
K-band Radar Unit: *Quick...*
9500ci: *Quick who?*
K-Band Radar Unit: *Quick Trigger YOU!!!*
9500ci: *Sorry, don't know you...* (And remains silent).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:08 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.