Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Max2 and Max

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old March 22nd, 2017
daveman327 daveman327 is offline
Junior Member
 
Join Date: Mar 2017
Posts: 2
Default Laser on start up

Hi everyone, just got a Max. When I power it up, regardless of where I am, the Laser alert comes on for about 20 seconds and then goes away. Doesn't matter where I am, in my garage at home, at work, at the grocery store, the golf course, etc. It powers on and then acts like it's being hit by laser and then goes away, like I said, after about 20 seconds or so. Just wanted to know if that is normal or if I should be contacting Escort about it directly. It's my first Escort radar detector and it's done this since day 1 out of the box, so I have nothing to compare it to. Thanks!
Reply With Quote
  #2  
Old March 22nd, 2017
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,179
Default

That is not normal.
If your car has any collision avoidance devices (or any internal led lighting) at all you will want to power up your MAX in a vehicle that does not have any to check if it's your car or the MAX.
Welcome to the forum and let us know what you find.

Last edited by poolmon; March 22nd, 2017 at 09:08 PM.
Reply With Quote
  #3  
Old March 22nd, 2017
DetectorDan DetectorDan is online now
Senior Member
 
Join Date: Dec 2016
Location: Ellicott City, MD
Posts: 528
Default

daveman327 -

By all means, call Escorts customer service about this. It isn't normal.

As poolmon states, if you can check the detector in a different car, please do so. But from what you describe, it's possible the detector needs service. Your detector is still under warranty. Take advantage of it.

Dan
Reply With Quote
  #4  
Old March 23rd, 2017
Zak Zak is offline
Senior Member
 
Join Date: Jan 2016
Posts: 252
Default

Quote:
Originally Posted by daveman327 View Post
Hi everyone, just got a Max. When I power it up, regardless of where I am, the Laser alert comes on for about 20 seconds and then goes away. Doesn't matter where I am, in my garage at home, at work, at the grocery store, the golf course, etc. It powers on and then acts like it's being hit by laser and then goes away, like I said, after about 20 seconds or so. Just wanted to know if that is normal or if I should be contacting Escort about it directly. It's my first Escort radar detector and it's done this since day 1 out of the box, so I have nothing to compare it to. Thanks!
Does your vehicle have LED lights in the front o the car at all? Fogs, headlights, even accent lighting or DRL's?
This many times will reflect off walls, like it does in my garage, every time I start my car.
Do you use a sunshade on the windshield? When I use my shade the metallic reflector on it causes the laser detection to go off.
__________________
Max 360
Max-2
Samsung Galaxy S7 Edge,
Android 7.0 (Nougat)
Reply With Quote
  #5  
Old March 27th, 2017
Mina Bekhit Mina Bekhit is offline
Junior Member
 
Join Date: Feb 2017
Posts: 10
Default

Quote:
Originally Posted by daveman327 View Post
Hi everyone, just got a Max. When I power it up, regardless of where I am, the Laser alert comes on for about 20 seconds and then goes away. Doesn't matter where I am, in my garage at home, at work, at the grocery store, the golf course, etc. It powers on and then acts like it's being hit by laser and then goes away, like I said, after about 20 seconds or so. Just wanted to know if that is normal or if I should be contacting Escort about it directly. It's my first Escort radar detector and it's done this since day 1 out of the box, so I have nothing to compare it to. Thanks!
I have an Infiniti G37 and my max does the same when it's close to the LCD if I use a mirror mount. Try to move the detector away from the LCD screen if you have one. Try to place the detector 2" higher than the dashboard.
Reply With Quote
  #6  
Old April 10th, 2017
bluez6 bluez6 is offline
Junior Member
 
Join Date: Apr 2017
Posts: 4
Default

I've only had my Max a few days and I'm having the same problem, but worse. First few days of use, didn't do it. Now Laser warning stayed on minutes and eventually shut off. First happened this morning after pulling out of the garage, but quickly shut off by the end of the driveway. The automatic garage door has a sensor for detecting on obstruction so I attributed it to that. 30 minute commute to work, it was fine. But then after work tonight in an open parking lot it happened again, but stayed on. Late day (no headlights) and later when almost dark. Also noticed that even when the alarm shut off, the yellow LED (alarm) on the smart power cord stays on. Cycled power several times, and problem stayed. Clearly something is wrong with it. No way it should have false alarm like that, headlights, LED display, or anything of the sort should not be triggering it. If that's the case then I'm returning it for my money back. This is a huge disappointment. Except for some firmware download type of cure, this is being returned.
Reply With Quote
  #7  
Old April 10th, 2017
Kruse's Avatar
Kruse Kruse is offline
Member
 
Join Date: Mar 2017
Location: Texas
Posts: 38
Default

Quote:
Originally Posted by Mina Bekhit View Post
I have an Infiniti G37 and my max does the same when it's close to the LCD if I use a mirror mount. Try to move the detector away from the LCD screen if you have one. Try to place the detector 2" higher than the dashboard.
I have seen this same issue when holding the Max 360 inside a Lexus and Toyota's both having an LCD. Never had the issue when the detector was properly mounted on the windshield.
__________________
Relax and Enjoy the Drive...

Escort Max 360 / Escort Live
Escort Passport 8500 X2
Escort 1982 Ver. - Coupled with '79 Pontiac Trans-Am
Reply With Quote
  #8  
Old April 10th, 2017
Mina Bekhit Mina Bekhit is offline
Junior Member
 
Join Date: Feb 2017
Posts: 10
Default

Quote:
Originally Posted by Kruse View Post
I have seen this same issue when holding the Max 360 inside a Lexus and Toyota's both having an LCD. Never had the issue when the detector was properly mounted on the windshield.
I have also tried my max close to the screen of my 2015 Nissan Pathfinder and it alerts to laser as well. The issue is worse when you start the car and then it goes off. Sometimes it goes on as well during driving. As long as you are away from the vertical projection of the screen, the Laser will not alert.
Reply With Quote
  #9  
Old April 13th, 2017
bluez6 bluez6 is offline
Junior Member
 
Join Date: Apr 2017
Posts: 4
Default

Intermittently when I turn on the Max it triggers a laser alert and does not stop. Does not appear to be related to my car's LCD display. Also the orange alert light on the smartcord is always on, even when there is no alert. I doubt it's related, seems like 2 problems. I think it's time to call and send it in for repair. This is a huge disappointment.
Reply With Quote
  #10  
Old 2 Weeks Ago
daveman327 daveman327 is offline
Junior Member
 
Join Date: Mar 2017
Posts: 2
Angry What Escort says

Thanks everyone for your input. I too have mine in an Infinity G37. Their customer service says that on start up of the vehicle, the car is putting off some kind of high power IR signal that is being picked up by the detector. They said I could return it and try to have the detector recalibrated, but no guarantees it will solve the issue. They said it doesn't happen will all cars, but with some it will occur.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:05 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2012 Escort Inc.