Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > RedLine EX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 19th, 2019
newzealandnick newzealandnick is offline
Junior Member
 
Join Date: Jan 2019
Posts: 2
Unhappy Weak/Late KA Alert

Hey team, I`ve had my Redline EX International or a number of months now, came from a 9500IX which was stolen from my car. Over the first few months of using it, I thought that I wasn't driving my usual routes or just must not be driving in areas where the cops are running radar or out with their laser gun. A few weekends ago, I drove past a cop who had someone pulled over on the other side of the road, literally as the front of my car passed the front of the car that was being pulled over, my radar detected a KA band, 2 bars. My 9500IX would have been screaming from at least a few hundred meters away. So I have since updated the software and performed a factory reset as I saw someone else had this issue on the forum but to no avail. Last night I got caught speeding, as the cop pulled up behind me, my radar alerted to a 1 bar KA band.

Has anyone else had this issue? I don't know how to fix it.

All my KA band alerts are also on which I did in the Escort Live App.
Reply With Quote
  #2  
Old January 19th, 2019
radarcc radarcc is offline
Banned
 
Join Date: Nov 2018
Posts: 117
Default

Quote:
Originally Posted by newzealandnick View Post
Hey team, I`ve had my Redline EX International or a number of months now, came from a 9500IX which was stolen from my car. Over the first few months of using it, I thought that I wasn't driving my usual routes or just must not be driving in areas where the cops are running radar or out with their laser gun. A few weekends ago, I drove past a cop who had someone pulled over on the other side of the road, literally as the front of my car passed the front of the car that was being pulled over, my radar detected a KA band, 2 bars. My 9500IX would have been screaming from at least a few hundred meters away. So I have since updated the software and performed a factory reset as I saw someone else had this issue on the forum but to no avail. Last night I got caught speeding, as the cop pulled up behind me, my radar alerted to a 1 bar KA band.

Has anyone else had this issue? I don't know how to fix it.

All my KA band alerts are also on which I did in the Escort Live App.
Sounds like you might possibly have a faulty unit. Nothing you can do to fix it yourself. Since you have had it for a number of months it looks like your only option is to call Escort and schedule a service for it.
Reply With Quote
  #3  
Old January 19th, 2019
newzealandnick newzealandnick is offline
Junior Member
 
Join Date: Jan 2019
Posts: 2
Default

Yeah, I thought it may have been but wanted to make sure I wasn't missing something. Thanks for that!
Reply With Quote
  #4  
Old January 20th, 2019
MONOPOLA MONOPOLA is offline
Junior Member
 
Join Date: Jul 2018
Location: BULGARIA
Posts: 27
Default

Quote:
Originally Posted by radarcc View Post
Sounds like you might possibly have a faulty unit. Nothing you can do to fix it yourself. Since you have had it for a number of months it looks like your only option is to call Escort and schedule a service for it.
Mine does the same, but alerting NOTHING,
No Laser, No K and No Ka detecting
I try sevrel times to get contacted with the “OFFICIAL RESELLER” from where i by the RD, and they advaice me to do hard reset and update the firmware again, but all the same - No Laser, No K and No Ka detecting!!!!(It was last year december, since then no answer from the “OFFICIAL RESELLER”) My RD is under warranty and my RD needs to be serviced, and i dont want to send my unit to usa or canada, dont want to spend over 200$ for shipment, i buy the RD from Europe, not from North America. What Escort Co. will do to repair my unit under warranty?
I pay over 700€( over 800 USD)

Last edited by flylow7f39; January 20th, 2019 at 05:40 PM.
Reply With Quote
  #5  
Old January 20th, 2019
richie_redbull richie_redbull is offline
Senior Member
 
Join Date: Dec 2012
Location: Westbank, British Columbia
Posts: 132
Default

I find mine with Ka, goes off basically when I'm right on top of the cop... I have yet to see a long range KA alert, best I've seen is maybe 2 blocks.. K however seems a bit better, which doesn't make sense as I think they are the same horn (correct me if I'm wrong). I find my Redline EX is a Honda detector, more that anything. Out of 200 alerts 1 will be a cop and 199 will be a Honda. It seems to have no where near the detection capabilities of my original Redline. I've had mine for a year, and keep hoping it's just that there aren't as many cops around and mine is working fine, but in the back of my mind, I keep thinking it's prolly got issues... just haven't called in to deal with tech support yet, I prolly should while mine is still under warranty...
Reply With Quote
  #6  
Old January 23rd, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,814
Default

Quote:
Originally Posted by MONOPOLA View Post
Mine does the same, but alerting NOTHING,
No Laser, No K and No Ka detecting
I try sevrel times to get contacted with the “OFFICIAL RESELLER” from where i by the RD, and they advaice me to do hard reset and update the firmware again, but all the same - No Laser, No K and No Ka detecting!!!!(It was last year december, since then no answer from the “OFFICIAL RESELLER”) My RD is under warranty and my RD needs to be serviced, and i dont want to send my unit to usa or canada, dont want to spend over 200$ for shipment, i buy the RD from Europe, not from North America. What Escort Co. will do to repair my unit under warranty?
I pay over 700€( over 800 USD)
Here is a list of our authorized. Please contact the appropriate one to have your detector serviced.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #7  
Old January 25th, 2019
crmgr crmgr is offline
Member
 
Join Date: Aug 2013
Location: Brunswick Hills, Ohio
Posts: 66
Default

Mine did the same thing. Would be almost passing a cop coming in the other direction before I got a weak alert. Sent it in for service in July. Came back strong and I thought corrected. Lately however, it seems to have gone back to the same routine. Passed a cop last evening in the opposite direction giving someone a ticket. Got a week Ka alert about 500 feet before I passed. Not sure why this is happening or if it's something with the cop's radar that operates with a weaker signal when not actively ticketing. Winter is not a good time to test since, area cops don't really like to get out in the cold.



Quote:
Originally Posted by newzealandnick View Post
Hey team, I`ve had my Redline EX International or a number of months now, came from a 9500IX which was stolen from my car. Over the first few months of using it, I thought that I wasn't driving my usual routes or just must not be driving in areas where the cops are running radar or out with their laser gun. A few weekends ago, I drove past a cop who had someone pulled over on the other side of the road, literally as the front of my car passed the front of the car that was being pulled over, my radar detected a KA band, 2 bars. My 9500IX would have been screaming from at least a few hundred meters away. So I have since updated the software and performed a factory reset as I saw someone else had this issue on the forum but to no avail. Last night I got caught speeding, as the cop pulled up behind me, my radar alerted to a 1 bar KA band.

Has anyone else had this issue? I don't know how to fix it.

All my KA band alerts are also on which I did in the Escort Live App.
Reply With Quote
  #8  
Old January 25th, 2019
richie_redbull richie_redbull is offline
Senior Member
 
Join Date: Dec 2012
Location: Westbank, British Columbia
Posts: 132
Default

I finally called tech support, I was told to reset the Redline EX back to factory settings and that would fix the issue... So I reset it... and nope.. no fix... Here is a video of tonight, showing how poor my Redline EX is working...

https://www.youtube.com/watch?v=Vqy0Nww65fI



Here is a map of where I was driving...



In the video, you can see the cops lights flashing as I am turning right, and the Redline EX didn't go off.... only after I round the corner and am almost on him, does it finally go off...

Last edited by flylow7f39; January 26th, 2019 at 01:34 AM. Reason: Fixed youtube link
Reply With Quote
  #9  
Old January 26th, 2019
SuperDave's Avatar
SuperDave SuperDave is offline
Member
 
Join Date: Mar 2017
Location: Louisville KY
Posts: 95
Default

That does seem short - however several factors may be in play - you came over a hill, the gun could be in his seat or if it’s in the front window it’s pointing away from you directly at the trunk of the car in front of him. But hey I’d send it in maybe, couldn’t hurt.
__________________
25 yr detector user

Max 360 Platinum
Escort IX
Redline
Passport X50
Whistler 1788
Uniden superwide
Cobra trapshooters
Fuzzbuster
Reply With Quote
  #10  
Old February 1st, 2019
wanderer1 wanderer1 is offline
Member
 
Join Date: Aug 2018
Location: American living in Flor-i-DAH
Posts: 68
Default

Yeah pretty short range, my X80 (when I use it) would probably alert at least a quarter mile in that situation. WOW
__________________
Tried almost all brands of detectors over the years, ESCORT won. Have owned original CM Escort w/mute, original Passport, Escort DSP (all time favorite, metal case, key, unreal range), Solo 5 battery pwr (I think), Passport 7500 (crap KA), Passport 8500 (better KA), Passport 8500 X50 (best KA), Passport X80 (not too bad), Escort IX (solidly built, really liked it but falsed a little too much) and currently a Max 360 BLE v 1.7

DRIVE SMARTER OR GET THE HELL OUTTA THE LEFT LANE
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.