Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #41  
Old February 27th, 2017
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 14,894
Default

It doesn't lose its sticky it gets covered in debris. If it is covered in debris then rinse it with water and rub the debris off of it. Shake it dry, don't use a towel or you'll re-apply lint/debris. It should then be just as sticky as when you first got it.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #42  
Old May 19th, 2017
Zak Zak is offline
Banned
 
Join Date: Jan 2016
Posts: 314
Default

Quote:
Originally Posted by GKAtascosa View Post
I had the same problem, but I'm always removing the mount...I don't want to advertise that I have a radar detector.
The problem is that the plastic tabs that attach to the suction cup start to spread apart causing it to go boom!
I fixed mine using 2 small pieces of a pencil eraser shoved into either side of the tab slots. No more flexing and no more boom!
Here is a pic. I know it's crude, but it works for me.


It's amazing that such a little thing could make such a big difference.
Escorts RD needs to seriously fix this flaw for those are constantly removing and re attaching the mount.
He didn't say it went boom, the cups just weren't sticky anymore.


I might also suggest that if you take it down a lot keep a plastic sandwich bag handy so when you take it down pop it in the bag and close it until you're ready to reinstall it. That will keep dust from accumulating on the cup.
Reply With Quote
  #43  
Old May 19th, 2017
GKAtascosa GKAtascosa is offline
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default

Quote:
Originally Posted by Wooddog44 View Post
On delivery day, about a month ago, I had my new 360 mounted and working but when I went to make an adjustment to the cup it "blew up". Spring went one way, little lever went another, cup went a third, etc...

Escort 2nd day aired me a new one, which has so far worked fine, but I'm concerned each time I flip the lever that it will again spontaneously disassemble...

Escort of course gave me the "party line" that it was an isolated defect but the fact that they were so quick to send another one, and didn't want the broken one back, makes me think it wasn't such an isolated problem... Anyone else experience anything like this?
I installed 2 pieces of pencil erasure on mine on either side of the mounting tab. This way they don't spread open and blow up.
Reply With Quote
  #44  
Old May 19th, 2017
GKAtascosa GKAtascosa is offline
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default

Quote:
Originally Posted by EscortRadar View Post
The area was reinforced. If you compare an old mount to a new one you can see the difference.
I bought a new one on July 16th last year and it did the same thing.
Had a replacement sent 3 months ago, and same thing.
I pull the lever down and use the rubber tip at the top of the suction cup to remove it.
Reply With Quote
  #45  
Old May 20th, 2017
GregK's Avatar
GregK GregK is offline
Senior Member
 
Join Date: Feb 2011
Location: Palatine, IL.
Posts: 714
Default

Quote:
Originally Posted by GKAtascosa View Post
I installed 2 pieces of pencil erasure on mine on either side of the mounting tab. This way they don't spread open and blow up.
Perhaps Escort could ship all their mounts with a complimentary pair of safety goggles? (Just Joking Escort)

Greg
__________________
Greg
<<<<<<<<<<<>>>>>>>>>>>
PLEASE...Help Save An Innocent Life !
www.aspca.org
Reply With Quote
  #46  
Old May 20th, 2017
GKAtascosa GKAtascosa is offline
Junior Member
 
Join Date: Jun 2016
Posts: 7
Default

Quote:
Originally Posted by GregK View Post
Perhaps Escort could ship all their mounts with a complimentary pair of safety goggles? (Just Joking Escort)

Greg
Escort said the mount was new and improved and that the unit wouldn't blow apart. WRONG. It's the same old mount, I've seen nothing in improvements.
Goggles..hehe..it's not that bad, but what is bad is when their "New" Mounts were supposedly fixed..I bought the 360 max and new mount. The mount blew apart, detector bounced off the dash, off the floor in my Jeep and out the door.
I didn't have the doors installed. There goes 650.00 bouncing down the highway. Hmmpph. I contacted them..waiting for a response.
I still have the suction cup on the windshield as a reminder.
Reply With Quote
  #47  
Old May 20th, 2017
Zak Zak is offline
Banned
 
Join Date: Jan 2016
Posts: 314
Default

I've had mine off several times, hasn't blown up yet.
Reply With Quote
  #48  
Old May 21st, 2017
DetectorDan DetectorDan is offline
Senior Member
 
Join Date: Dec 2016
Location: Ellicott City, MD
Posts: 655
Default

Quote:
The mount blew apart, detector bounced off the dash, off the floor in my Jeep and out the door.
I didn't have the doors installed. There goes 650.00 bouncing down the highway.
OMG....this has to be a first. You don't say how fast you were going or how you stopped on a highway to retrieve the detector but it's probably - at a minimum - pretty scratched up.

Does it still seem to work?

Dan
Reply With Quote
  #49  
Old May 31st, 2017
wv2sc wv2sc is offline
Junior Member
 
Join Date: May 2017
Posts: 1
Default

My sticky cup dropped after sitting in hot weather this week. When it dropped it hit my navigation screen and put a one inch gouge in the screen. This is the third time it had dropped not leaving me feeling secure with it not damaging something else in my new car or itself. I wish Escort had another option for mounting the 360.
Reply With Quote
  #50  
Old May 31st, 2017
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 5,808
Default

Quote:
Originally Posted by wv2sc View Post
My sticky cup dropped after sitting in hot weather this week. When it dropped it hit my navigation screen and put a one inch gouge in the screen. This is the third time it had dropped not leaving me feeling secure with it not damaging something else in my new car or itself. I wish Escort had another option for mounting the 360.
That's unfortunate, wv2sc. I've never had the experience that you've had. For me, though, even using the windshield mounts, I only use them when I'm not driving in my own car. Speaking ONLY for me, when I'm driving my own car, I use a Blendmount with my detector attached on my RVM.

There are pro's and con's about using a third-party mounting solution, but speaking for me, I'm good with decision.
__________________


Countermeasures:

Radar Detectors: Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:28 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2017 Escort Inc.