Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport iQ

Notices

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old March 25th, 2011
bigalinwv bigalinwv is offline
Senior Member
 
Join Date: Jul 2009
Posts: 603
Default Some iQ observations

I finally decided to get an iQ. There are some good and bad with this thing.

Good:
-showing 4 signals with the frequency is awesome
-highly configurable

Bad:
-K band is definitely not on par with my 9500s, where my 9500s have falses, sometimes this iQ doesn't even see the signal
-Almost every time I hit a button (virtual) on the screen, I have to hit it twice, even though it makes the little chirping sound, confirming the press of the button
-On bumpy roads, this thing vibrates a lot! I think it must be due to the weight, but it sure doesn't seem impossible to create a rock-solid mount.
-No "multiple signals detected"????
-The voice is, well, not entirely clear, and NO WHERE NEAR LOUD ENOUGH. I feel sorry for anybody who listens to music in their car, they'll never hear this thing at all. With no radio on, and the windows down, it is barely audible. This is the most puzzling part of the detector. How can my 9500s, and nearly every other detector I've ever owned, be so much louder than this one? This one appears to have a huge speaker.

One puzzling thing that happened last night: I entered an address for a long trip we are going to take soon. The iQ showed 246 miles to the destination, which is fairly close to the Google maps mileage. Then when I clicked on the "Go To", it entered the map mode. Now it shows 361 miles!. How the heck that that be? And then I wanted to see the directions for the entire trip, so following directions, I pressed on the first direction turn. It shows the first 4 or 5 directions (the whole screen). BUT it won't show anymore turns after that. The arrow on the bottom that should allow me to keep scrolling down, isn't white, and can't be pressed.

I now officially offer my services to Escort for free. These problems should have been addressed long ago. And I say again, those that create these, must not use them, it's impossible to believe that. There's no way anybody could have used this iQ for any period of time and not seen and discovered the same problems I have, totally impossible.

That said, I'm still keeping it, hoping there are fixes to come!
  #2  
Old March 25th, 2011
snoopyc4's Avatar
snoopyc4 snoopyc4 is offline
Senior Member
 
Join Date: Oct 2009
Posts: 564
Default

Quote:
showing 4 signals with the frequency is awesome
And it shows which ones are locked out if you're in a false alert area correct?

Quote:
Bad:
-K band is definitely not on par with my 9500s, where my 9500s have falses, sometimes this iQ doesn't even see the signal
Interesting. How about Ka?
__________________
ESCORT Radar Detectors:
Escort 9500ci
Escort Redline
Escort 9500i
SOLO S2

My Channel:http://www.youtube.com/user/rrdtogo
  #3  
Old March 25th, 2011
bigalinwv bigalinwv is offline
Senior Member
 
Join Date: Jul 2009
Posts: 603
Default

Quote:
Originally Posted by snoopyc4 View Post
And it shows which ones are locked out if you're in a false alert area correct?



Interesting. How about Ka?
Yes, the locked out signals are in grey, whereas the non-locked out signals are in red.

Haven't seen any Ka since I got it. Figures....
  #4  
Old March 26th, 2011
bigalinwv bigalinwv is offline
Senior Member
 
Join Date: Jul 2009
Posts: 603
Default

Yesterday on a 30 minute drive the iQ didn't get a GPS signal at all. When I got to my destination, I went thru the menu and did a factory reset, BINGO it knew instantly where I was. Strange.
  #5  
Old March 27th, 2011
bigalinwv bigalinwv is offline
Senior Member
 
Join Date: Jul 2009
Posts: 603
Default

I am going on a long trip soon, the one I referenced earlier in this post. Just as a backup, I got my Garmin 255w out today(which is only 3 months old). The 255w doesn't even recognize the address!! Unbelievable, but the iQ sees the address, but the 255w doesn't. Weird, they're both Navteq data.
  #6  
Old March 28th, 2011
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,362
Default

Thanks for the feedback bigalinwv. We will definitely be releasing updates for the iQ which should address some of your concerns. I don't have any specific times when these will be made available but one should be released soon.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
  #7  
Old March 29th, 2011
bigalinwv bigalinwv is offline
Senior Member
 
Join Date: Jul 2009
Posts: 603
Default

I appreciate it. I am not giving up on this thing. I drove today with it and was going to video it, but it was so overcast, the videos would have been too dark. The next sunny day, I intend to make some good videos of the features.

I was promised that by RadarRoy a few months ago but it never materialized. I guess if he can't do his best Billy Mays impression, he won't make a video?? Too bad Escort doesn't use VeilGuy first, his videos say more in the first few minutes than RR's does for the entire length. RR doesn't tell you anything you can't read on the webpage.
  #8  
Old March 30th, 2011
Hot Rod Ford Hot Rod Ford is offline
Member
 
Join Date: Aug 2010
Posts: 47
Default

I was wondering if anyone had a conflicting experience with the IQ and another installed radar detector.

My friend bought a used car (Camaro) that actually has a Whistler Pro 3600 in it. I don't know much about it except some bad reviews about the Whistler brand in general from RadarRoy and other sites.

Anyway...we put the IQ on the window and it seems to go off consistently when the Whistler is on. When the Whistler is off the IQ acts normally.

I told him to shut off the Whistler and just use the IQ which I think is better but was just curious to see what the conflict could be.

Did anyone have conflicts with a 9500ci for instance?
  #9  
Old March 30th, 2011
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,362
Default

These two detectors will definitely interfere with each other. Interference will cause false alerts, poor detection range and missing alerts.

The only detectors that do not emit any signals which will cause interference with other detectors are our detectors which use the M3 antenna. These are: RedLine, Passport 9500ci, Beltronics STi Driver, STi-R (obsolete), and the STi-R Plus.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
  #10  
Old April 6th, 2011
Hot Rod Ford Hot Rod Ford is offline
Member
 
Join Date: Aug 2010
Posts: 47
Default

Thank Escort

We did what you said and sure enough the IQ was doing its thing without much errors.

Still having some issues with the Navigation and every so often the radar detector part does not seem to want to work.

We did have some nice saves (about 3) on Route 17 blowing past the outlets.

I came across this and was wondering if there was any chance Escort would be doing something like this in the future for certain autos. I can really feel something like this setup in my Caddy.



http://www.youtube.com/watch?v=sCWhzV0R-Ig
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:33 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.