Escort Radar Forum  

Go Back   Escort Radar Forum > Escort Live! > Escort Live! for Android

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old April 13th, 2018
ckelly33 ckelly33 is offline
Junior Member
 
Join Date: Nov 2017
Posts: 4
Default Escort Live rarely connects via Bluetooth (Android)

I have a new Max360c and Escort Live installed on my Samsung Galaxy S8 (Verizon, running stock Oreo).

RARELY can I get Escort Live and my Max360c to connect via Bluetooth. In the app, the Bluetooth icon in the top right corner is red. When i tap it, the devices available to connect show but my Max360c isn't there (though I am sitting beside it and it is powered on). Occasionally - maybe once in 10 tries- will it show up and allow me to connect.

I have deleted the app, re-paired the Max360 with my phone and reinstalled the app and tried again. Nothing works.

I called in yesterday and, unfortunately, it happened to function properly at the time. The tech support person told me that not only should it show every time, the app should auto-connect to the device when the app is opened. The app has NEVER auto-connected to the Max360c.

When it does connect (rare!), most of the time settings changes to the device don't transfer from the app to the device. Not sure what that's about either.

Is all of this 'normal'? Do I have a defective device?

Seems like a waste of my 'free' escort live that came with my device
Reply With Quote
  #2  
Old April 17th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 15,909
Default

I doubt if there is an issue with your detector. If there was then it would never connect. Try un-pairing and re-pairing your MAX 360c. This can solve bluetooth connection issues.

Due to app resource restrictions while backgrounded that were introduced in Android 8, Escort Live's functionality while it is in the background has been limited. Hopefully we can work around these issues.

Our devices auto-connect excellently on iPhone. This is not due to a limitation with the Escort Live app or the bluetooth implementation that we use in our devices.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #3  
Old April 23rd, 2018
Stinger22 Stinger22 is offline
Junior Member
 
Join Date: Mar 2017
Posts: 16
Default

MIne will autoconnect about half the time. When it doesn't I have to touch the BT icon and pick from a list. Why can't the app be limited to just the Max 360 there is no reason for it to connect to anything else. Then if I am not battling the "Connect connect to GPS services" even my phone GPS is working perfectly, it connects but I just get a blue BT icone with the PSL should be on the Max 360. It won't show the actual PSL just my actual MPH next to it.
Samsung S8
Android 8
Reply With Quote
  #4  
Old May 7th, 2018
enigma-2 enigma-2 is offline
Member
 
Join Date: Feb 2015
Location: Northern Indiana
Posts: 58
Default

Try clearing your cache.

setting->> applications
tap 3-dots at top right, select "show system apps"
Scrowl down, tap "bluetooth share"
tap "clear data" and "clear cache".
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:26 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.