Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport X70

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old May 4th, 2016
Thedeadhead71's Avatar
Thedeadhead71 Thedeadhead71 is offline
Senior Member
 
Join Date: Mar 2016
Location: Clayton NC
Posts: 132
Default

Quote:
Originally Posted by EscortRadar View Post
You should try one 30 days risk free
Why? you designed the X70 to be nice n' quiet. the slight K range hit does not bother me with TSR or auto mode.

The redesigned spec meter that shows both the frequency and the ghz is the best. I never used spec on the silver X50 because it only showed the frequency.

X70 firmware wish list
Performance
1) any improvement to filtering is welcome
Cosmetic
1) able to turn the volt Box and grayed-out Bluetooth on the left display off so the meter takes up the full window
2) reduce the time the signal strength displays after passing a radar
3) Forget arrows on the lower priced models. on the far right of the display or in place of the voltage box , have a box that is color-coded. Red box means radar signal is in the front and yellow box means it's from behind or not from the front

Last edited by Thedeadhead71; May 4th, 2016 at 09:10 PM.
Reply With Quote
  #12  
Old May 30th, 2016
Thedeadhead71's Avatar
Thedeadhead71 Thedeadhead71 is offline
Senior Member
 
Join Date: Mar 2016
Location: Clayton NC
Posts: 132
Default Signal Stength ramp up

Seen this discuss somewhere but I can't remember where. Just got back from road trips countering 6 Ka signals -one stationary; others moving

These are my settings
RDR off
Pop off
KaN2 off
TSR on
Auto mode and sometimes Highway mode

I have encountered since owning this thing only Ka- 34.7, 33.8, and 35.5. I have not encountered real K band or X band.

I've seen people discuss for other models but it seems the signal strength meter ramp-up is not the same as in the old X 50. the old X50 would often display a single signal strength bar on a weak Ka signal while approaching the source and then it would beep up to more bars as the signal increased. This will be for constant on radar.

On the X 70 it seems it just starts out on a double bar signal strength alert as the lowest before beeping up to more bars.

There is a difference in the X70 from the X50 in how it initially reports a weak signal. I have noticed this on Ka. I have not had an opportunity to test K band but I might with my radar gun system.

I prefer the X50 signal strength ramp up.

I am running in spec mode- it shows signal strength and the frequency

And also passing a signal, it continues to beep up for too long in my opinion. It takes longer for the signal strength meter to die down after passing a radar pointed in your direction.

For example. When I activate my K band radar gun, The detector goes to full signal strength. When I turn the radar off, it continues to beep and hold full strength for too long after the radar is off.

I am thinking I would almost prefer real time signal strength. So when the signal is turned off, the signal strength immediately starts to die down rather than hang for several seconds before dying down.

Last edited by Thedeadhead71; May 30th, 2016 at 08:41 PM.
Reply With Quote
  #13  
Old May 31st, 2016
Thedeadhead71's Avatar
Thedeadhead71 Thedeadhead71 is offline
Senior Member
 
Join Date: Mar 2016
Location: Clayton NC
Posts: 132
Default

update May 31- our local PD left a Ka radar on in their parking lot (in parked patrol car). I made 2 passes down the street. The X 70 starts out with 2 bars signal strength in spec mode and not one like the old models as they ramp up. This needs fixin in firmware update. Ramp up does not feel right.

It's like having TSR on for a Ka band.

In standard meter mode it starts out with 3 signal strength bars. See video here from this morning https://www.youtube.com/watch?v=wwnQXFhBiG8

I will test K band constant-on soon to check ramp up with TSR off.

And lastly. The ramp down takes almost six seconds . See video below.
https://youtube.com/watch?v=h9C1LLF8...ature=youtu.be

Ramp down would be better to real-time or no more than 2 - 3 sec max.

Last edited by Thedeadhead71; June 1st, 2016 at 08:38 PM.
Reply With Quote
  #14  
Old June 2nd, 2016
Thedeadhead71's Avatar
Thedeadhead71 Thedeadhead71 is offline
Senior Member
 
Join Date: Mar 2016
Location: Clayton NC
Posts: 132
Default

Unacceptably long ramp down of X70 with Passport 4500 and old Passport. Note the old Passport reacts faster to I/O shots.

https://www.youtube.com/watch?v=hoxN...ature=youtu.be


And note that the 360 has / had a similar ramp up thing starting out with 2-3 bars while approaching constant on K

https://www.youtube.com/watch?v=kEXOa48nwww

So in conclusion to the above, I would recommend that escort take a look at how the X70 ramps up when receiving a signal and how it ramps down when the signal is turned off. One video from the Max 360 also shows a quick ramp up as well so I am thinking this may affect other models, not just the X70. This has nothing to do with performance but how signal strength is reported and interpreted. New escort users may not notice, but as a long-time escort user the ramp up/down just does not feel right.

Last edited by Thedeadhead71; June 6th, 2016 at 02:12 PM.
Reply With Quote
  #15  
Old June 6th, 2016
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 15,678
Default

Never operate detectors together to judge their performance. They interfere with each other causing randomly poor performance and false alerts. More modern detectors incorporate more advanced false alert filtering which will be impacted moreso by this interference.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #16  
Old June 27th, 2016
Thedeadhead71's Avatar
Thedeadhead71 Thedeadhead71 is offline
Senior Member
 
Join Date: Mar 2016
Location: Clayton NC
Posts: 132
Default

Ok but there were other videos without mixing up detectors together. It's a long ramp down delay. Please fix👍

Had a X70 save today from constant on Ka 34.699. This is at least 2 saves since March but it might be save 3. I have run into a lot of radar but sometimes it's in heavy traffic or in other non threatening road situations.

I would have been nailed today. I entered the highway off axis and as I swung around I was getting an alert with about four or five signal strength bars. Looking at Google earth this was at 1 mile from the source. So it would have picked up the signal even at a greater distance than that. I was the only one out on the road and I was in a hurry but I wasn't even speeding since I picked up the alert upon entering the highway from the ramp. But I probably would have been. 😀
Reply With Quote
  #17  
Old July 10th, 2016
Thedeadhead71's Avatar
Thedeadhead71 Thedeadhead71 is offline
Senior Member
 
Join Date: Mar 2016
Location: Clayton NC
Posts: 132
Default

Save today. 1.2 mile alert to Ka 35.5. Stationary constant on.

Last edited by Thedeadhead71; July 11th, 2016 at 12:07 PM.
Reply With Quote
  #18  
Old July 11th, 2016
Sebehk Sebehk is offline
Junior Member
 
Join Date: Jun 2016
Location: Pueblo West, CO
Posts: 5
Default

I've had my X70 for almost 3 weeks and so far I love it. I use it in conjunction with Waze. I like my X70 so far. (I'm still debating on whether to get Escort Live or not.)

I always get multiple false K-band alerts by passing through major street intersections. I pass by two stationary K-band radar speed signs on my way to work. Luckily, the local and state police use Ka-band radar, most of the time they are always on.

Saved me once on my way home from work, about 1.5 miles looking downhill. I can see the patrol car on the side; Ka-band of course.

--->Robert
8-)
Reply With Quote
  #19  
Old July 11th, 2016
Thedeadhead71's Avatar
Thedeadhead71 Thedeadhead71 is offline
Senior Member
 
Join Date: Mar 2016
Location: Clayton NC
Posts: 132
Default

I thought I was the only one with an X70. Everyone seems to be hanging out at the 360 or Max pages.

Are you running in Auto with TSR on? That will help. I haven't run into real police K in about 3 years. 99% Ka 34.7 or 35.5. Last ran into laser over a year ago.

It would be safe to turn K off in my daily commute.

Last edited by Thedeadhead71; July 11th, 2016 at 04:02 PM.
Reply With Quote
  #20  
Old July 11th, 2016
Sebehk Sebehk is offline
Junior Member
 
Join Date: Jun 2016
Location: Pueblo West, CO
Posts: 5
Default

Quote:
Originally Posted by Thedeadhead71 View Post
Are you running in Auto with TSR on? That will help. I haven't run into real police K in about 3 years. 99% Ka 34.7 or 35.5. Last ran into laser over a year ago.
I am running my X70 with defaults, including TSR ON and AUTO.

Quote:
Originally Posted by Thedeadhead71 View Post
It would be safe to turn K off in my daily commute.
I will do that after another week or so of driving around with the X70, taking mental notes when/where false K-band alerts happen. Of course, if I had Escort Live, I probably wouldn't have to do that.

--->Robert
8-)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:52 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.