Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > ESCORT iX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #31  
Old August 10th, 2017
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,278
Default

Quote:
Originally Posted by Bluelinex View Post
Just got my IX back, they sent me a new one. It's working reading all of the red light and speed cam locations as it should. When I called Escort to set up the new one she told me a fix will be coming.
So for now I will not update it as that's when the problems start. As they say "If not broke don't fix it" for now.
1. Did they give you any details on when it occurs, upon either:
A. Merging the Database, or
B. Updating the Software

2. Did they specify where the fix will be implemented:
A. Software/Firmware
B. Detector Tools Interface
C. Hardware

Would like to know too from ER if possible in case we get more inquiries here so we can respond accurately to other affected users?
Reply With Quote
  #32  
Old August 10th, 2017
rmreid10 rmreid10 is offline
Member
 
Join Date: Jul 2010
Location: TN
Posts: 80
Default

Quote:
Originally Posted by Bluelinex View Post
Just got my IX back, they sent me a new one. It's working reading all of the red light and speed cam locations as it should. When I called Escort to set up the new one she told me a fix will be coming.
So for now I will not update it as that's when the problems start. As they say "If not broke don't fix it" for now.
Well maybe there is hope for me then, as mine just went back for the 3rd time for the same issue
Reply With Quote
  #33  
Old August 12th, 2017
Bluelinex Bluelinex is offline
Member
 
Join Date: Jun 2017
Posts: 30
Default

I would give them a call. After 3 times going back you think they would just replace it. It's costing them $$ in UPS fees alone. The tech guy told me not to update it for a month or two. To me that means they know about it but do not have a fix.
When I set up the new one the girl at Escort told me a fix will be coming but no time table as to when. If you do get a replacement DO NOT UPDATE IT for a while.
Reply With Quote
  #34  
Old August 12th, 2017
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,278
Default

I have not heard anything further.

I was curious, I see at least one of you with the issue also runs Escort Live (EL). Have any of you had the issue without ever running EL on your detector?
[just trying to narrow this down]
Reply With Quote
  #35  
Old August 12th, 2017
Bluelinex Bluelinex is offline
Member
 
Join Date: Jun 2017
Posts: 30
Default

From what I've seen, if your using Escort Live the detector works fine. That tells me the detector is having problems accessing the the data on its own. It's a software problem in the detector.
Reply With Quote
  #36  
Old August 12th, 2017
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,278
Default

Quote:
Originally Posted by Bluelinex View Post
From what I've seen, if your using Escort Live the detector works fine. That tells me the detector is having problems accessing the the data on its own. It's a software problem in the detector.
That's what I was trying to narrow down. Is it a problem with the software/firmware on the detector, a problem with the Detector Tools software in Merging it, or something else? That was why I was wondering if anyone had a working database on a standalone detector (no EL used ever), updated it through a Merge on DT, then lost their Database (or lost access to it but it was still resident on the RD).
Reply With Quote
  #37  
Old August 14th, 2017
rmreid10 rmreid10 is offline
Member
 
Join Date: Jul 2010
Location: TN
Posts: 80
Default

Quote:
Originally Posted by Bluelinex View Post
I would give them a call. After 3 times going back you think they would just replace it. It's costing them $$ in UPS fees alone. The tech guy told me not to update it for a month or two. To me that means they know about it but do not have a fix.
When I set up the new one the girl at Escort told me a fix will be coming but no time table as to when. If you do get a replacement DO NOT UPDATE IT for a while.
I have called 3 or 4 times now (I had to call each time to get the return authorization) disappointing and very frustrating at best
Reply With Quote
  #38  
Old August 17th, 2017
Bluelinex Bluelinex is offline
Member
 
Join Date: Jun 2017
Posts: 30
Default

Call them. Your IX should be in warranty, you should get a replacement like I did. My new IX is working as it should, they back up there products.
Reply With Quote
  #39  
Old August 18th, 2017
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 14,894
Default

I have been taking care of rmreid10 regarding this.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #40  
Old August 21st, 2017
rmreid10 rmreid10 is offline
Member
 
Join Date: Jul 2010
Location: TN
Posts: 80
Default

Quote:
Originally Posted by EscortRadar View Post
I have been taking care of rmreid10 regarding this.
Agreed, my iX arrives back today and I am hoping that all is fixed
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:13 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2017 Escort Inc.