Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 8500, X50, X50 Black

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 16th, 2017
Elchison Elchison is offline
Junior Member
 
Join Date: Jul 2017
Posts: 2
Default X50 Blue M4 6.5 - Not detected by Escort Live App

I have a Silver X50 (FCC:QKLX5M4 v6.5). Using Escort Live on my iPhone, I connect to the new SmartCordLive, but it says no detector is connected (yellow BT symbol).

When the system is powered, the X50 reboots for several minutes before staying powered. There is no indication in the Escort Live App that it is ever detected or any kind of firmware is being updated. I have reset the detector (to get the firmware version). The early reboots do not seem to be a loose power cord.

Any troubleshooting suggestions?
Reply With Quote
  #2  
Old July 17th, 2017
Butcher318 Butcher318 is offline
Senior Member
 
Join Date: Dec 2011
Location: Indiana
Posts: 1,638
Default

Has this setup worked in the past or is this a new Escort live system? Reason i ask is the 8500 line is older and has been discontinued, it might no longer work with Escort live. Just curious.
Reply With Quote
  #3  
Old July 17th, 2017
Elchison Elchison is offline
Junior Member
 
Join Date: Jul 2017
Posts: 2
Default New setup

I just purchased the Smart Cord Live cable after checking with Escort Sales that my X50 was compatible. I provided the FCC code and S/N in order for them to confirm it would work. Maybe they misled me in order to make the sale? I certainly dont want to pay an extra $40 and shipping to have my unit updated. If that's the case, I will return the cord.
Reply With Quote
  #4  
Old July 17th, 2017
Butcher318 Butcher318 is offline
Senior Member
 
Join Date: Dec 2011
Location: Indiana
Posts: 1,638
Default

Call them and check.
Reply With Quote
  #5  
Old July 18th, 2017
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 14,603
Default

If your SmartCord Live cord has only one button on it, a Mute button, then you will need send it to us to have it updated before it will work with the SmartCord Live cord.

To set this up please contact us at the number in my signature below.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:47 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2017 Escort Inc.