Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > RedLine EX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old February 6th, 2019
richie_redbull richie_redbull is offline
Senior Member
 
Join Date: Dec 2012
Location: Westbank, British Columbia
Posts: 129
Default

Quote:
Originally Posted by EscortRadar View Post
If you are using Auto sensitivity, that is certainly limiting K band. The first encounter first alerted at 23 mph. With Auto mode's speed sensitivity active it will greatly limit sensitivity. That first encounter was also when going over-the-hill which limits detection.
I am always running on Highway all the time...
Reply With Quote
  #22  
Old February 14th, 2019
crmgr crmgr is offline
Member
 
Join Date: Aug 2013
Location: Brunswick Hills, Ohio
Posts: 64
Default

Update: Bought a Max360C yesterday. Had a problem with installing the latest firmware. Install said complete, but unit would not turn on. Was ready to take it back, but tried removing all the installed updates and re-installing everything. That worked and it appears to be running OK.

Drove the same route I always do, with the same two cops running radar. My EX never made a sound. Always thought they were not running radar. My 360C went off full KA band before I even rounded the corner. Could not believe it. Means I've been running the EX totally exposed and not even realizing the unit had a problem. Same problem I had when I sent it in to Escort last July. Means another trip and they say $99.00 for a tuneup.

I don't get it. Why does the EX have this problem? Ready to just throw it in a drawer.


Quote:
Originally Posted by crmgr View Post
Mine did the same thing. Would be almost passing a cop coming in the other direction before I got a weak alert. Sent it in for service in July. Came back strong and I thought corrected. Lately however, it seems to have gone back to the same routine. Passed a cop last evening in the opposite direction giving someone a ticket. Got a week Ka alert about 500 feet before I passed. Not sure why this is happening or if it's something with the cop's radar that operates with a weaker signal when not actively ticketing. Winter is not a good time to test since, area cops don't really like to get out in the cold.
Reply With Quote
  #23  
Old February 14th, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,650
Default

It sounds like you might have Ka band, or parts of Ka band, disabled. Reset your EX to factory defaults and try it. To do this, hold down MARK and BRT buttons while turning on the unit until you see the "factory settings restored" message, then release the buttons.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #24  
Old February 14th, 2019
crmgr crmgr is offline
Member
 
Join Date: Aug 2013
Location: Brunswick Hills, Ohio
Posts: 64
Default

Originally KA segmented 2,5,6,8 active. Then enabled all bands. No change. Also tried doing a reset, since another post said CS at Escort told him that was a fix. No change. Frustrating. Would have been nice to get an error message.


Quote:
Originally Posted by EscortRadar View Post
It sounds like you might have Ka band, or parts of Ka band, disabled. Reset your EX to factory defaults and try it. To do this, hold down MARK and BRT buttons while turning on the unit until you see the "factory settings restored" message, then release the buttons.
Reply With Quote
  #25  
Old February 15th, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,650
Default

It is unusual to not get an error message when there are detection issues. It sounds like it will need to be serviced. To set this up, please contact our service department at the number in my signature below.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #26  
Old February 15th, 2019
crmgr crmgr is offline
Member
 
Join Date: Aug 2013
Location: Brunswick Hills, Ohio
Posts: 64
Default

Thanks. Will think it over. Not sure I want to throw more good money after bad.


Quote:
Originally Posted by EscortRadar View Post
It is unusual to not get an error message when there are detection issues. It sounds like it will need to be serviced. To set this up, please contact our service department at the number in my signature below.
Reply With Quote
  #27  
Old February 15th, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,650
Default

Also be aware that if you were running both detectors together, the MAX 360c will interfere with the RedLine EX causing it to false and miss alerts.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #28  
Old February 15th, 2019
crmgr crmgr is offline
Member
 
Join Date: Aug 2013
Location: Brunswick Hills, Ohio
Posts: 64
Default

No, never run two detectors at the same time. Actually, really like the Max 360C. Had another detector and it's nice to have arrows back again. Just disappointed in the performance of the EX, especially after the previous service check.


Quote:
Originally Posted by EscortRadar View Post
Also be aware that if you were running both detectors together, the MAX 360c will interfere with the RedLine EX causing it to false and miss alerts.

Last edited by EscortRadar; February 15th, 2019 at 12:35 PM. Reason: replaced competitor name
Reply With Quote
  #29  
Old February 22nd, 2019
richie_redbull richie_redbull is offline
Senior Member
 
Join Date: Dec 2012
Location: Westbank, British Columbia
Posts: 129
Default

Quote:
Originally Posted by EscortRadar View Post
At the tolerances these detectors deal with, it is full of "moving parts". The slight variances with temperature changes (which are digitally compensated), or the torque of the receiver screws, or how certain components are soldered, all affect sensitivity and tuning. It will not hurt to have it checked out.

If you are using Auto sensitivity, that is certainly limiting K band. The first encounter first alerted at 23 mph. With Auto mode's speed sensitivity active it will greatly limit sensitivity. That first encounter was also when going over-the-hill which limits detection.
Well the good news is I sent it in for repair, I just got it back today and the work order said the antenna module was replaced.... Yay!

So I plug it in and comes up with a big shiny Check FR <sigh>, but I thought lets see....I take it out for a drive, well now it doesn't detect anything. I can't even get a door sensor or speed sign to light it up... guess it's going back again. This $40 in shipping now times 2 is expensive. Is there a way I can fix Check FR myself?
Reply With Quote
  #30  
Old February 25th, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,650
Default

We will pay for the return shipping. Please contact our service department to set this up.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:50 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.