Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > ZW5 and ZR5

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old October 30th, 2010
JimLev JimLev is offline
Junior Member
 
Join Date: Feb 2010
Location: MA.
Posts: 23
Default ZR3 and 8500 "Speed Cal" question

I was driving along yesterday, doubt there was any radar or laser where I was driving as there was nothing there and no place for anyone to hide.
For no reason I can figure my 8500 display switched from Auto to Speed Cal.
I've never seen Speed Cal before, it didn't go away until I turned off my ZR3.
I then turned the ZR3 back on and all was fine.
Reply With Quote
  #2  
Old November 1st, 2010
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,741
Default

You are probably referring to "self cal" message, there is no "speed cal" message in the Passport 8500.

This is normal but should not happen regularly. If you see it every time you use the Passport then it is probably malfunctioning.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:14 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.