Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > ESCORT iX

Reply
 
Thread Tools Search this Thread Display Modes
  #41  
Old 1 Day Ago
rmreid10 rmreid10 is offline
Member
 
Join Date: Jul 2010
Location: TN
Posts: 72
Default

Quote:
Originally Posted by rmreid10 View Post
Agreed, my iX arrives back today and I am hoping that all is fixed
Still not working correctly
Works fine with Escort Live on detecting red light cameras does not detect red light cameras without EL
HELP!
Reply With Quote
  #42  
Old 1 Day Ago
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 5,596
Default

Quote:
Originally Posted by rmreid10 View Post
Still not working correctly
Works fine with Escort Live on detecting red light cameras does not detect red light cameras without EL
HELP!
To detect RLCs without using Escort Live, you have to have a Defender subscription. When you bought your iX, it came with a 90 day trial. If it's beyond 90 days, you'll have to purchase a subscription.

With the subscription, you'll update the Defender database on your detector using Detector Tools. However, I've heard some reports that suggest that doing so removes your saved lockouts, and that a new version of DT is forthcoming to address this. I can't confirm whether or not this is so, because I don't own an iX.

EL accesses the Defender DB in the cloud while it's running, but you'll need a subscription if you want your iX to warn you of RLCs using the detector alone.
__________________


Countermeasures:

Radar Detectors: Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)

Last edited by TBNTX; 1 Day Ago at 01:54 PM.
Reply With Quote
  #43  
Old 1 Day Ago
rmreid10 rmreid10 is offline
Member
 
Join Date: Jul 2010
Location: TN
Posts: 72
Default

Quote:
Originally Posted by TBNTX View Post
To detect RLCs without using Escort Live, you have to have a Defender subscription. When you bought your iX, it came with a 90 day trial. If it's beyond 90 days, you'll have to purchase a subscription.

With the subscription, you'll update the Defender database on your detector using Detector Tools. However, I've heard some reports that suggest that doing so removes your saved lockouts, and that a new version of DT is forthcoming to address this. I can't confirm whether or not this is so, because I don't own an iX.

EL accesses the Defender DB in the cloud while it's running, but you'll need a subscription if you want your iX to warn you of RLCs using the detector alone.
I have a Defender DB subscription ( 3 year) plus the Defender DB was updated while it was at the shop for a 3rd time and my iX has a clear view to the sky. My faithful 9500ix and MAX detect the redlight cameras perfectly so the issue is inherent to my iX
Reply With Quote
  #44  
Old 1 Day Ago
poolmon poolmon is online now
Senior Member
 
Join Date: Jul 2009
Posts: 1,253
Default

Quote:
Originally Posted by rmreid10 View Post
Still not working correctly
Works fine with Escort Live on detecting red light cameras does not detect red light cameras without EL
HELP!
If I understand you correctly (and please correct me if I am wrong):
1. Your iX was working both with and without EL when you got it.
2. You then updated (Merge and/or Software . . not sure which, please specify)
3. After the Update your iX only gives GPS alerts with EL.
4. You returned the iX to ESCORT and they serviced it, whereupon I assume as normal procedure they checked for both the most recent Software and Database, checked that it is functioning correctly, and returned it to you.
5. Your newly serviced iX still cannot access the Defender Database unless hooked to EL.

If this is not the case please advise, if it is you may want to send a message to ER directly. Let us know how it turns out.

EDIT 1: You posted just before I submitted this
EDIT 2: After you got it back, did you test it immediately without retrying any update and/or attempting to hook to EL? If you did then that could be a further clue.

Last edited by poolmon; 1 Day Ago at 02:11 PM.
Reply With Quote
  #45  
Old 23 Hours Ago
Bluelinex Bluelinex is offline
Junior Member
 
Join Date: Jun 2017
Posts: 21
Default

Did they send you a replacement detector?? You will have a new serial number and will have to reregester it with Escort. The replacement is working as it should but I have not updated it since I got.
Gonig to wait a while before I do that.
Reply With Quote
  #46  
Old 9 Hours Ago
rmreid10 rmreid10 is offline
Member
 
Join Date: Jul 2010
Location: TN
Posts: 72
Default

Quote:
Originally Posted by poolmon View Post
If I understand you correctly (and please correct me if I am wrong):
1. Your iX was working both with and without EL when you got it.
2. You then updated (Merge and/or Software . . not sure which, please specify)
3. After the Update your iX only gives GPS alerts with EL.
4. You returned the iX to ESCORT and they serviced it, whereupon I assume as normal procedure they checked for both the most recent Software and Database, checked that it is functioning correctly, and returned it to you.
5. Your newly serviced iX still cannot access the Defender Database unless hooked to EL.

If this is not the case please advise, if it is you may want to send a message to ER directly. Let us know how it turns out.

EDIT 1: You posted just before I submitted this
EDIT 2: After you got it back, did you test it immediately without retrying any update and/or attempting to hook to EL? If you did then that could be a further clue.
1. Yes although I did have an issue early on that was thought to be caused by corrupted memory
2. Even if I don't get a email for an update I check for updates once a month using the most up to date detector tools
3. Seems to be specific to redlight cameras in my daily travel path as well as a speed camera and redlight cameras in another section of the state
4. Correct 3x's
5. It appears that "some" redlight and speed cameras are not detected without using EL

EDIT 2: I did not update the iX, I simply plugged it in and drove with it to known redlight cameras in my area

Last edited by rmreid10; 9 Hours Ago at 08:10 AM.
Reply With Quote
  #47  
Old 9 Hours Ago
rmreid10 rmreid10 is offline
Member
 
Join Date: Jul 2010
Location: TN
Posts: 72
Default

Quote:
Originally Posted by Bluelinex View Post
Did they send you a replacement detector?? You will have a new serial number and will have to reregester it with Escort. The replacement is working as it should but I have not updated it since I got.
Gonig to wait a while before I do that.
No they did not
Reply With Quote
  #48  
Old 7 Hours Ago
poolmon poolmon is online now
Senior Member
 
Join Date: Jul 2009
Posts: 1,253
Default

Quote:
Originally Posted by rmreid10 View Post
1. Yes although I did have an issue early on that was thought to be caused by corrupted memory
2. Even if I don't get a email for an update I check for updates once a month using the most up to date detector tools
3. Seems to be specific to redlight cameras in my daily travel path as well as a speed camera and redlight cameras in another section of the state
4. Correct 3x's
5. It appears that "some" redlight and speed cameras are not detected without using EL

EDIT 2: I did not update the iX, I simply plugged it in and drove with it to known redlight cameras in my area
Given Item #1's initial possible "memory issue"; and, #5 that only some RLC's don't alert without EL (so impliedly some do) I'd contact ER directly with a private message to try to get it resolved, especially since you own 2 other Escort GPS detectors and know how they should operate and to which you can compare your new iX's operation.
Reply With Quote
  #49  
Old 17 Minutes Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 14,604
Default

Thank you for posting a follow up rmreid10. I'm sorry to hear that it is still doing this. On the bright side, today I was able to reproduce ESCORT iX not alerting to every camera in the directions that it should. Some it will alert to while others it will not. We are looking into this. I will post updates about it here in this thread. The solution most probably will be in the form of firmware and/or database updates so please do not set up a service order if you are experiencing this.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:20 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2017 Escort Inc.