Escort Radar Forum  

Go Back   Escort Radar Forum > Dash Cameras > M1

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 3 Weeks Ago
J-Persons J-Persons is offline
Junior Member
 
Join Date: Apr 2019
Posts: 11
Default Steady green

Noticed while driving that the blinking green went to a steady green. A check of the owners manual states the steady green lamp indicates when connected to a computer. This happened while driving and connected to the Max360,not the computer.
Reply With Quote
  #2  
Old 3 Weeks Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,905
Default

Unfortunately it sounds like there is an issue with your M1, requiring it to be serviced. To set this up, please contact us at the number in my signature below.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or you can fill out a repair form and we will contact you.
Reply With Quote
  #3  
Old 2 Weeks Ago
Darkmann Darkmann is offline
Senior Member
 
Join Date: Dec 2010
Posts: 240
Default

This happened to me a couple of weeks ago. The unit returned to normal after a power cycle. It has functioned normal since.
Reply With Quote
  #4  
Old 1 Week Ago
J-Persons J-Persons is offline
Junior Member
 
Join Date: Apr 2019
Posts: 11
Default

Thanks for the reply. I installed a new 32gb card and it is working normally now.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:43 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.