Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 8500, X50, X50 Black

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 6th, 2019
Nine_c1's Avatar
Nine_c1 Nine_c1 is offline
Armchair Expert
 
Join Date: Jul 2009
Posts: 2,577
Default 8500 X50 Escort Live Cord issue

Just bought a new 8500 X50 (re-skinned S55) and a new EscortLive cord and have an issue. Powering on the 8500 X50 with the Live cord causes the detector to keep powering on and off until I unplug the cord and plug it back in. Doesn't matter if I unplug the cord from the detector end or from the lighter socket......either way solves the power cycling issue. This happens any time I power the detector off and on using the pwr button. If I leave the detector powered on and switch it off with the ignition, then back on with the ignition, no issue.


This is also the only way I can get the detector to connect to EscortLive…..ie, if I pwr the detector off using the pwr button, I can only get it back on and connected by unplugging the detector and then plugging it back in, then I can connect to EscortLive.


No problems powering the detector on / off using the standard power cord.


Is this an issue with the new detector or the new Live cord?
Reply With Quote
  #2  
Old October 3rd, 2019
The Only Sarge's Avatar
The Only Sarge The Only Sarge is offline
Senior Member
 
Join Date: Jan 2015
Location: South Texas
Posts: 152
Default

Hey guy....
Few years back Escort had us update just the smart cord....I do not remember the specifics other than one would connect just the cord ( no RD) to Detector Tools and update the software to the cord specific....then connect the RD. IIRC some experienced this rebooting thing when the cord was not updated.....Hope this may help but my memory is shot. I am old and cannot remember what I did yesterday
__________________
7 decades of hauling butt...................
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:39 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.