Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > SOLO S4

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old December 29th, 2016
PMike PMike is offline
Junior Member
 
Join Date: Dec 2016
Posts: 7
Default Escort Solo 2

I recently had my cordless Solo 2 repaired and since it's return it has alerted on 2 different occasions with a steady or consistent beep, but no indication of laser or radar on the signal meter. Both times I ended up unplugging the power cord to turn off the device and upon powering it back up the problem is resolved. Does anyone have any idea what might be happening? I am thinking it might be best to return it to the service center to be checked out....
Reply With Quote
  #2  
Old March 23rd, 2017
troymon troymon is offline
Junior Member
 
Join Date: Feb 2017
Posts: 7
Default

I would return it to the service center. Have a Solo 2 on another car. Although I have no problems with it, I find its range and sensitivity not too powerful when compared to corded radars. Bought an Escort Solo2 because it was on sale at 4wheelonline.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:25 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2017 Escort Inc.