Escort Radar Forum  

Go Back   Escort Radar Forum > Detector Accessories > Power Cords

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 3 Weeks Ago
Xman95 Xman95 is offline
Junior Member
 
Join Date: May 2019
Posts: 2
Default Original version of smartcord live not working

I have the original smartcord live for my original max. I just got my detector back from the factory after doing the $140 refurbishment program after the detector sat in a drawer for months after it died. It doesnít seem to be getting power and max doesnít turn on. Does this cord have a fuse that I can replace or do I need to send it back to escort as well?
Reply With Quote
  #2  
Old 3 Weeks Ago
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Senior Member
 
Join Date: Apr 2019
Location: USA
Posts: 281
Default

Quote:
Originally Posted by Xman95 View Post
I have the original smartcord live for my original max. I just got my detector back from the factory after doing the $140 refurbishment program after the detector sat in a drawer for months after it died. It doesnít seem to be getting power and max doesnít turn on. Does this cord have a fuse that I can replace or do I need to send it back to escort as well?
Check your power source to be sure you donít have a blown fuse in your car. Try different outlets to rule this out.
__________________
I use the following Escort Products

Escort Redline EX
Max360c with wifi
M1 Dash cam with both detectors
Escort Live
ZR5 Shifters
Reply With Quote
  #3  
Old 3 Weeks Ago
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,641
Default

Quote:
Originally Posted by Xman95 View Post
Does this cord have a fuse that I can replace or do I need to send it back to escort as well?
I took a regular SmartCord apart and it did not have an internal replaceable fuse inside.
Suggest you test as indicated above and if not successful contact Escort. Also, if you tested the MAX with its regular (non-live) SmartCord and it turns on, you can skip further testing and just call Escort to get the Live Cord repaired.

Last edited by poolmon; 3 Weeks Ago at 11:03 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.