Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 9500ix, S75G

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old December 27th, 2011
CarterMarkham's Avatar
CarterMarkham CarterMarkham is offline
Member
 
Join Date: Dec 2011
Location: Maine
Posts: 46
Default New 9500ix Racer Limited Edition - Replacement

I just got this radar detector for christmas, beautiful device! I am talking with tech support now. The problem I am having is it is constantly throwing a KA band alert. As soon as my car is started, it will take a few seconds, and then throw a KA alert. I work close to home, maybe 6 miles or so, a little highway, then city. Is this normal? I also have Live! as well.

My car does not have any parking assist, adaptive cruise etc. I have a 2011 Subaru Impreza WRX, Nav, Remote Start.
Reply With Quote
  #2  
Old December 27th, 2011
CarterMarkham's Avatar
CarterMarkham CarterMarkham is offline
Member
 
Join Date: Dec 2011
Location: Maine
Posts: 46
Default

So after the convo with tech support wanting to replace the unit. I tried a couple things.
First I updated the detector software, even though it was already up to date. Then I tried it in my roommates truck, Toyota Tacoma, no options at all. The detector worked without any problems.
I tried it again in my car and it again worked fine.

I don't know what happened, but is it possible the original software on the detector itself was corrupt??
Reply With Quote
  #3  
Old December 28th, 2011
CarterMarkham's Avatar
CarterMarkham CarterMarkham is offline
Member
 
Join Date: Dec 2011
Location: Maine
Posts: 46
Default

Again tonight it just started throwing off random K bands, I kept locking them out via the iPhone App, but another one would pop right up. In one residential area I locked out 4 K band alerts.
Reply With Quote
  #4  
Old December 28th, 2011
powerpickle's Avatar
powerpickle powerpickle is offline
Senior Member
 
Join Date: Dec 2010
Location: Michigan
Posts: 1,244
Default

Is this your first detector? If not what was the previous
Do you live near traffic flow sensors?
Try spec mode and log the frequency of the ka band. Below 33.8 will be a false
Have you driven by those 4 lock out locations 3 times or more and still have the lock out ? provided you are using autolearn
Are the random alerts low level or high level? Start out low and get stronger?
The alerts could be falses that you didn't know about.
Some could be real.
You could have a faulty unit.
It could be your car causing enough interference and causing falses.
Have you tried it in your friends truck again with out any issues?
__________________
Curiosity was framed,ignorance killed the cat
MAX/Redline/Solo S3/V1 3.892/8500 X50 (S7) RX65 (S7) 8500 X50 Black/LI dual
Won an Ipad3 from Escort
Reply With Quote
  #5  
Old December 28th, 2011
CarterMarkham's Avatar
CarterMarkham CarterMarkham is offline
Member
 
Join Date: Dec 2011
Location: Maine
Posts: 46
Default

My last detector was a Beltronics RX55.
The only sensors I know of in my area are red light traffic sensors, in ground, and stop light mounted.
I have not driven by these areas more than twice.
Autolearn is on.
The random alerts are Max strength.
I don't believe my car is putting out any interference.
I haven't tried it again in my buddies truck.
Reply With Quote
  #6  
Old December 29th, 2011
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,780
Default

Is TSR enabled on your new 9500ix? If not then enable it as the K band alerts sound just like alerts from radar based traffic flow sensors.

Almost all red light camera sensors do not use radar or laser so a normal detector will not alert to them. Your 9500ix will alert to them due to the location being stored in it's GPS database (Defender).
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #7  
Old December 29th, 2011
CarterMarkham's Avatar
CarterMarkham CarterMarkham is offline
Member
 
Join Date: Dec 2011
Location: Maine
Posts: 46
Default

IS TSR enabled by default? I am using all the default settings.
Reply With Quote
  #8  
Old December 29th, 2011
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,780
Default

TSR should be on by default then. We recently changed this as the default setting so I would check to be sure. Just go into preferences menu and go through all the bands to see the TSR setting.

If you receive these alerts in the same locations then the detector is probably working like it should. If it is consistently alerting no matter where you are then it will probably need to be sent in for service or replacement.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #9  
Old January 3rd, 2012
CarterMarkham's Avatar
CarterMarkham CarterMarkham is offline
Member
 
Join Date: Dec 2011
Location: Maine
Posts: 46
Default

So I have sent it back. On a ride yesterday about 25 min long, I was getting constant K band alert.
Reply With Quote
  #10  
Old January 3rd, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,780
Default

If you had it replaced and you are still having the same behavior then it's not the detector malfunctioning. They are probably just normal false alerts in your area that the detector needs to learn and store as falses. The 9500ix is a much better performing detector than the RX55 which may be why your RX55 didn't alert to them.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:26 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.