Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360c

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old June 13th, 2019
JonUrban JonUrban is offline
Junior Member
 
Join Date: Aug 2018
Posts: 5
Default False Laser Alerts

I've had my 360c for almost a year (10 months) and for the first 6 it was fine, but somewhere along the way it either started failing on it's own or an update messed it up, but I am getting a lot of Laser alerts in places where I know there are no lasers.

I live out in the woods, so to speak, and I'll be driving down a road in the middle of nowhere and get a laser alert. I slow down, look around, and nothing. Sometimes I get one in my driveway! Other times I could just be cruising down a random road and it goes off, but I see nothing anywhere.

Should I send this thing in for a factory check out? It's a bit annoying and I am afraid one day it will be real!

THANKS

PS - I leave my unit on "AUTO" and it is connected to the WiFi in my car whenever it's on.
Reply With Quote
  #2  
Old June 13th, 2019
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,671
Default

A car's navigation screen can set off the 360c laser alert and some cell phone displays in close proximity. Have you made any such changes to/in your vehicle since the first 6 months that could affect it? Have you moved its mount from where it was?

The Auto setting has no bearing on laser alerts nor should the wifi (however if you just switched over to wifi no harm to try without it). If no resolution is found I'd first try doing and Update All Software under the Device tab in DT Pro via computer, immediately power it up with 12 volts to complete the install and if still no change I'd send it in. Don't update the Database immediately after a Software Update until first re-powering it with 12 volts to allow the software install to complete. You can then disconnect from 12 volts and revisit DT Pro to update the Database.

Last edited by poolmon; June 13th, 2019 at 04:38 PM.
Reply With Quote
  #3  
Old June 13th, 2019
Tingtang Tingtang is offline
Member
 
Join Date: May 2019
Posts: 36
Default

Quote:
Originally Posted by poolmon View Post
A car's navigation screen can set off the 360c laser alert and some cell phone displays in close proximity. Have you made any such changes to/in your vehicle since the first 6 months that could affect it? Have you moved its mount from where it was?

The Auto setting has no bearing on laser alerts nor should the wifi (however if you just switched over to wifi no harm to try without it). If no resolution is found I'd first try doing and Update All Software under the Device tab in DT Pro via computer, immediately power it up with 12 volts to complete the install and if still no change I'd send it in. Don't update the Database immediately after a Software Update until first re-powering it with 12 volts to allow the software install to complete. You can then disconnect from 12 volts and revisit DT Pro to update the Database.
What about ATMs? I think it was a false, car was perpendicular to road, but my laser went off on my 360c while i was inserting my card into the ATM
Reply With Quote
  #4  
Old June 14th, 2019
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,473
Default

Quote:
Originally Posted by Tingtang View Post
What about ATMs? I think it was a false, car was perpendicular to road, but my laser went off on my 360c while i was inserting my card into the ATM
Any LED screen has the potential to trigger a false laser alert. Try going to a Sonic drive-in and park next to one of their LED order-placement screens.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Escort M1 and Thinkware F750
Reply With Quote
  #5  
Old June 16th, 2019
JonUrban JonUrban is offline
Junior Member
 
Join Date: Aug 2018
Posts: 5
Default

Quote:
Originally Posted by poolmon View Post
A car's navigation screen can set off the 360c laser alert and some cell phone displays in close proximity. Have you made any such changes to/in your vehicle since the first 6 months that could affect it? Have you moved its mount from where it was?

The Auto setting has no bearing on laser alerts nor should the wifi (however if you just switched over to wifi no harm to try without it). If no resolution is found I'd first try doing and Update All Software under the Device tab in DT Pro via computer, immediately power it up with 12 volts to complete the install and if still no change I'd send it in. Don't update the Database immediately after a Software Update until first re-powering it with 12 volts to allow the software install to complete. You can then disconnect from 12 volts and revisit DT Pro to update the Database.
Thanks! I will try using DT Pro. Never had used it, but I'll research how
Reply With Quote
  #6  
Old June 16th, 2019
JonUrban JonUrban is offline
Junior Member
 
Join Date: Aug 2018
Posts: 5
Default

My laptop does not seem to have enough USB power to power the 360c. It lights up when I plug it in, but it instantly displays "Low Voltage". "Powering down...please unplug".

Is that normal or am I using a bad cable?

EDIT: NEVERMIND! I plugged it into my desktop USB 2.1 port and it lit up. USB 3.0 ports did the same thing. (FYI)

Last edited by JonUrban; June 16th, 2019 at 04:41 PM.
Reply With Quote
  #7  
Old June 16th, 2019
JonUrban JonUrban is offline
Junior Member
 
Join Date: Aug 2018
Posts: 5
Default

Quote:
Originally Posted by poolmon View Post
...... If no resolution is found I'd first try doing and Update All Software under the Device tab in DT Pro via computer, immediately power it up with 12 volts to complete the install and if still no change.
OK, did that. Reloaded the firmware then brought it to the car. It started up, then it asked if I wanted to update the database so I let it do it right there. Took a bit but it did that without issue. About a minute later, BOOM!, Laser Alert. In my driveway. No laser in sight.

I powered it down, then up, moved it around the car, nothing. Near the NAV display, near the rear view mirror, nothing - then again - LASER ALERT. It didn't matter where I moved it.

I will take it with me into the real world tomorrow and see how it works out, but I think I am going to have to send it in for a check-up.

Is there a place to email for RMA's or whatever the process is?

Thanks for your help with this.
Reply With Quote
  #8  
Old June 16th, 2019
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,671
Default

Quote:
Originally Posted by JonUrban View Post

Is there a place to email for RMA's or whatever the process is?

Thanks for your help with this.
No, you just need to call for RMA. They will take care of you.
Reply With Quote
  #9  
Old June 19th, 2019
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,671
Default

Your newly developed issue may be that you are now running software 1.9.

I have just read on another forum quite a few reports (7 at last count) that indicate that after 1.9 was installed a substantial number of laser falses are occurring. These reports are from advanced users who are very familiar with their units.

Escort may want to take a look at the feedback over there to check on this.
I'm still on 1.8.

Last edited by poolmon; June 19th, 2019 at 11:13 AM.
Reply With Quote
  #10  
Old June 22nd, 2019
Tingtang Tingtang is offline
Member
 
Join Date: May 2019
Posts: 36
Default

Quote:
Originally Posted by poolmon View Post
Your newly developed issue may be that you are now running software 1.9.

I have just read on another forum quite a few reports (7 at last count) that indicate that after 1.9 was installed a substantial number of laser falses are occurring. These reports are from advanced users who are very familiar with their units.

Escort may want to take a look at the feedback over there to check on this.
I'm still on 1.8.
So do they tend to get things done quicker or give us a little more than just "we are aware working on it" to advance users issues? Honestly I gave up on getting my 360c to work like its described.. I just stopped speeding all together.. all the Ka bands I've encountered so far, have only given me a full on alert when I'm within 50-75 ft.. I get random laser hits once a day, each time I was just waiting to be pulled over thinkin I got tagged, but nothing.. kinda stressful so I just dont go fast anymore. Maybe my entire vehicle is leaking radar, since I get the same k frequency when I out my sunshade up 😂
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:06 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.