Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > ESCORT iX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old March 5th, 2019
kd4fpt kd4fpt is offline
Junior Member
 
Join Date: May 2016
Posts: 5
Default Honda bumper sensor causing false alarm

Hi folks!
It seems like recently I have been getting a lot of false alarms going off on my iX. When I first got this Escort if I drove near a Cadillac the alarm would go off and now it is doing it on new Honda cars and vans.
Has anyone experienced this or am I the only one? Its been since December since I updated the software.
Thanks for reading
Reply With Quote
  #2  
Old March 5th, 2019
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,509
Default

Quote:
Originally Posted by kd4fpt View Post
Hi folks!
It seems like recently I have been getting a lot of false alarms going off on my iX. When I first got this Escort if I drove near a Cadillac the alarm would go off and now it is doing it on new Honda cars and vans.
Has anyone experienced this or am I the only one? Its been since December since I updated the software.
Thanks for reading
Hondas are among the worst offenders of false alerts. Search the forum, and you'll learn so. Nevertheless, the iX is an analog detector. For the best-possible rejection of false alerts caused by CAS/BSM "driver-assist" on-vehicle systems, consider upgrading to a digital detector in the Max family. In my experience, the detectors in the Max series are virtually "dead-quiet" when encountering CAS/BSM.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Escort M1 and Thinkware F750

Last edited by TBNTX; March 5th, 2019 at 10:12 PM.
Reply With Quote
  #3  
Old March 5th, 2019
Butcher318 Butcher318 is offline
Armchair Expert
 
Join Date: Dec 2011
Location: Indiana
Posts: 2,038
Default

Quote:
Originally Posted by kd4fpt View Post
Hi folks!
It seems like recently I have been getting a lot of false alarms going off on my iX. When I first got this Escort if I drove near a Cadillac the alarm would go off and now it is doing it on new Honda cars and vans.
Has anyone experienced this or am I the only one? Its been since December since I updated the software.
Thanks for reading
Yes, happens every day to some degree to every detector user now. Check through the forum
and read up on new vehicle safety systems that operate on the same frequency as police K band. Your IX filters better then the old 9500 models but not as well as the Max and 360 models.
Reply With Quote
Reply

Tags
false alarm

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:18 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.