Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 9th, 2019
Maddmaster's Avatar
Maddmaster Maddmaster is offline
Senior Member
 
Join Date: Oct 2009
Posts: 231
Default Max 360 Bluetooth Not connecting with EL

I have tried everything to get the the Max 360 and EL to connect using my Samsung Note 9. I have deleted, unpaired, reloaded EL App, powered RD and Note 9 off. Powered on same time and individually. Used EL settings menu to select Max 360 to connect. Indicator in EL App spins then times out. Anyone else having this issue. I contacted customer service and have done everything they had me do several times.
Reply With Quote
  #2  
Old July 9th, 2019
Mochi Mochi is offline
Junior Member
 
Join Date: Jul 2019
Posts: 2
Angry

Quote:
Originally Posted by Maddmaster View Post
I have tried everything to get the the Max 360 and EL to connect using my Samsung Note 9. I have deleted, unpaired, reloaded EL App, powered RD and Note 9 off. Powered on same time and individually. Used EL settings menu to select Max 360 to connect. Indicator in EL App spins then times out. Anyone else having this issue. I contacted customer service and have done everything they had me do several times.
See my post regarding my disappointment with the Max 360. There are tons of posts around regarding Bluetooth problems as well as the dimming display to the point of it being unreadable, even at night. It's obvious that their quality has disappeared and Escort isn't interested in helping those that have spent a lot of money with them.
Reply With Quote
  #3  
Old July 10th, 2019
Maddmaster's Avatar
Maddmaster Maddmaster is offline
Senior Member
 
Join Date: Oct 2009
Posts: 231
Default

It's always been an issue for me but since I had the EL hard wired module (Max360 was connected to it) most times the Bluetooth connected to it. Now since I changed cars and that module is gone, the Max360 Bluetooth is needed. Calling Customer Service again today.
Reply With Quote
  #4  
Old July 16th, 2019
SmoovC SmoovC is offline
Member
 
Join Date: Feb 2015
Posts: 74
Default

We had success connecting to the 360 with formerly owned S8+ phones by turning off Dual Audio in the Bluetooth settings.
__________________
DD: 2014 Cadillac CTS V-Sport Premium
RD: 360c w/ Blendmount
WiFi: Mito in-car hotspot (Verizon)
Phone: Pixel 3 XL 128GB Android 10 (Verizon)
Media: Android Auto
Dashcam: F770 2 ch F & R w/ park mode
Reply With Quote
  #5  
Old July 24th, 2019
Radarkat Radarkat is offline
Junior Member
 
Join Date: Jun 2019
Posts: 10
Default

My 360 has stopped connecting instantly too. It did at the beginning. Running iPhone XS Max iOS 12.4
Reply With Quote
  #6  
Old August 27th, 2019
Maddmaster's Avatar
Maddmaster Maddmaster is offline
Senior Member
 
Join Date: Oct 2009
Posts: 231
Default

Quote:
Originally Posted by Maddmaster View Post
It's always been an issue for me but since I had the EL hard wired module (Max360 was connected to it) most times the Bluetooth connected to it. Now since I changed cars and that module is gone, the Max360 Bluetooth is needed. Calling Customer Service again today.
I sent my 360 in for service (of course it was out of warranty). Itís works as it should now with no Bluetooth connectivity issues.
Reply With Quote
  #7  
Old September 20th, 2019
dtgriffi dtgriffi is offline
Member
 
Join Date: Nov 2011
Posts: 90
Default

Quote:
Originally Posted by Radarkat View Post
My 360 has stopped connecting instantly too. It did at the beginning. Running iPhone XS Max iOS 12.4
I'm sure you are aware of the delay setting in EL. If you haven't, check to make sure it is still instant (0). I have mine set to 5 seconds. iPhone 7.
Reply With Quote
  #8  
Old November 9th, 2019
SimonSays SimonSays is offline
Junior Member
 
Join Date: Nov 2019
Posts: 12
Default

I've had endless issues with the BT connection between my MAX360 and EL. Recently upgraded my iPhone X to the new iPhone 11 Pro, and it's still an issue.

As soon as I launch EL, I can see the BT logo on the Max360 display, but 8 times out of 10, the Max360 does not show the max speed display.

On the iPhone, the BT logo "flickers" in the EL app.

Sometimes it will connect after a while, sometimes if I turn off the Max360 and on again, it will connect, sometimes it connects after restarting the EL app...

I update the Max360 regularly, and even upgraded the Escort Detector tools on my Mac to 2.4.17 today and did a manual update of the firmware.

Any ideas what else I can do to fix it? It's super annoying.
Reply With Quote
  #9  
Old November 9th, 2019
mtime mtime is offline
Member
 
Join Date: Jun 2015
Posts: 74
Default

Quote:
Originally Posted by SimonSays View Post
I've had endless issues with the BT connection between my MAX360 and EL. Recently upgraded my iPhone X to the new iPhone 11 Pro, and it's still an issue.

As soon as I launch EL, I can see the BT logo on the Max360 display, but 8 times out of 10, the Max360 does not show the max speed display.

On the iPhone, the BT logo "flickers" in the EL app.

Sometimes it will connect after a while, sometimes if I turn off the Max360 and on again, it will connect, sometimes it connects after restarting the EL app...

I update the Max360 regularly, and even upgraded the Escort Detector tools on my Mac to 2.4.17 today and did a manual update of the firmware.

Any ideas what else I can do to fix it? It's super annoying.
On the Max360, BT connection is different depending on the serial number. 79xxx serial number series connect through iPhone BT settings, while the newer Max360's connect through the EL app. Which Max 360 do you have?
Reply With Quote
  #10  
Old November 23rd, 2019
SimonSays SimonSays is offline
Junior Member
 
Join Date: Nov 2019
Posts: 12
Default

Quote:
Originally Posted by mtime View Post
On the Max360, BT connection is different depending on the serial number. 79xxx serial number series connect through iPhone BT settings, while the newer Max360's connect through the EL app. Which Max 360 do you have?
My Serial starts with 85.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:25 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.