Escort Radar Forum  

Go Back   Escort Radar Forum > Escort Live! > Escort Live! for iPhone

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old April 9th, 2019
DynDuo DynDuo is offline
Junior Member
 
Join Date: Dec 2014
Location: Houston, TX
Posts: 15
Default New Version of ESCORT Live for iOS

The new version just came out today and it's a HUGE improvement! Thank you, ESCORT!
__________________
Current:
ESCORT Max 360C
ESCORT M1
ESCORT Live Premium (Charter Member)

Retired:
ESCORT MAX II Platinum
Direct Wire SmartCord Blue
Passport 9500ix (Blue)
Passport 9500ix (Red)
SmartCord Live - iPhone x2
Passport 8500
Passport 7500
Escort (Original)
Reply With Quote
  #2  
Old April 9th, 2019
suby01 suby01 is offline
Member
 
Join Date: Jul 2012
Posts: 96
Default

Quote:
Originally Posted by DynDuo View Post
The new version just came out today and it's a HUGE improvement! Thank you, ESCORT!
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAHHHHHHHHHHH.
you beat me to it. I was really really hoping to be the first one to post. WOOT. I need to. Want to leave work like now. To try it out.
Reply With Quote
  #3  
Old April 9th, 2019
Adrian97c's Avatar
Adrian97c Adrian97c is offline
Member
 
Join Date: Apr 2016
Posts: 69
Default




Sent from my iPhone using Tapatalk
__________________
2016 Camaro 2SS
iPhone 7+ iOS 11 (beta 9)
Max 360 v1.6
Reply With Quote
  #4  
Old April 9th, 2019
fasttr fasttr is offline
Junior Member
 
Join Date: Apr 2019
Posts: 11
Default Can’t login with new app

Anyone else having this problem. Continue to get invalid username/password even though the credentials work fine on the old app version...

Should add iPhone X running 12.2

Last edited by fasttr; April 9th, 2019 at 04:37 PM.
Reply With Quote
  #5  
Old April 9th, 2019
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,473
Default

Quote:
Originally Posted by fasttr View Post
Anyone else having this problem. Continue to get invalid username/password even though the credentials work fine on the old app version...

Should add iPhone X running 12.2
I've had no issues at all.

Please refrain from cross-posting. Thank you.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Escort M1 and Thinkware F750
Reply With Quote
  #6  
Old April 9th, 2019
gruversm's Avatar
gruversm gruversm is offline
Junior Member
 
Join Date: Jan 2014
Location: Michigan
Posts: 15
Send a message via MSN to gruversm
Default

I have a “subscription has expired” error message now. I’m paid through 2021.
__________________
IX
Reply With Quote
  #7  
Old April 9th, 2019
resthome resthome is offline
Junior Member
 
Join Date: May 2013
Posts: 29
Default

Quote:
Originally Posted by gruversm View Post
I have a “subscription has expired” error message now. I’m paid through 2021.
I had that message with the old app and it was because my IX serial number was not associated with the account I was logging into. It was the serial number from my old 9500ci so had to have them transfer the IX serial number to that account.
Reply With Quote
  #8  
Old April 9th, 2019
gruversm's Avatar
gruversm gruversm is offline
Junior Member
 
Join Date: Jan 2014
Location: Michigan
Posts: 15
Send a message via MSN to gruversm
Default

I only have had this issue with the new update. I logged out and then logged back in with no luck.
__________________
IX
Reply With Quote
  #9  
Old April 10th, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,780
Default

Quote:
Originally Posted by gruversm View Post
I only have had this issue with the new update. I logged out and then logged back in with no luck.
Connecting your detector to your phone and running Escort Live should resolve it.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #10  
Old April 29th, 2019
crh24's Avatar
crh24 crh24 is offline
Senior Member
 
Join Date: Jan 2010
Location: About 9 miles SW of Salem, Oregon
Posts: 182
Default

UPDATE:
I was able to connect immediately on my iPad Pro so I knew the problem was with my iPhone. A hard reset fixed the problem.
==========

I've been using the new version for a while. I had difficulty getting the app to see the radar detector, an original MAX. I tried forgetting and repairing the smart cord, didn't work. I uninstalled the app and re-installed. That worked.

This morning it's happened again, the app cannot find the MAX. I tried all of the same steps again and still couldn't get it to find the max.

Any suggestions?

My iPhone is the XS Max and the OS is the current release.
__________________
MAX 360c v 1.9
MAX v 1.11
9500ix
EL for iPhone; EL version is always the latest
iPhone XS Max (512GB); iOS version is always the latest
iPad Pro 12.9 Gen 2 (512GB); iOS version is always the latest
iDevice carrier is AT&T
'07 Honda Pilot EX-L 4d 4x4
Pioneer Z140BH head unit

Last edited by crh24; May 1st, 2019 at 11:15 PM. Reason: Update
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:34 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.