Escort Radar Forum  

Go Back   Escort Radar Forum > Dash Cameras > M1

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #51  
Old May 24th, 2019
Cloxo Cloxo is offline
Junior Member
 
Join Date: Apr 2013
Posts: 2
Default

Quote:
Originally Posted by TonyRI View Post
I agree. It would have been better as solid green. I have occasionally thought that my right blinker was on with the flashing green LED when catching it from the corner of my eye.
It is particularly problematic at night. I think I will need to cover it with tape!
Reply With Quote
  #52  
Old May 24th, 2019
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 347
Default

Quote:
Originally Posted by Cloxo View Post
It is particularly problematic at night. I think I will need to cover it with tape!
A small piece of black tape would do the trick for sure.
__________________
I use the following Escort Products

Escort Redline EX
Max360c with wifi
M1 Dash cam with both detectors
Escort Live
ZR5 Shifters
------------------------------------------------------------
Reply With Quote
  #53  
Old May 24th, 2019
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,473
Default

Quote:
Originally Posted by Skyrider View Post
Thanks! Yes I have a blendmount and have ordered the additional hardware to attach the M1.
I use a Blendmount, myself. Be aware that when you tighten the knurl, it can squeeze BM’s mounting yoke together too much, causing the M1 dashcam to become tilted.

Be prepared to add some thin metal washers between the tube and the sides of the BM yoke. I posted this solution on the forum, and I’ll try to find it.

EDIT: I found my post about the remedy.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Escort M1 and Thinkware F750

Last edited by TBNTX; May 24th, 2019 at 07:29 PM.
Reply With Quote
  #54  
Old May 25th, 2019
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 347
Default

Quote:
Originally Posted by TBNTX View Post
I use a Blendmount, myself. Be aware that when you tighten the knurl, it can squeeze BMís mounting yoke together too much, causing the M1 dashcam to become tilted.

Be prepared to add some thin metal washers between the tube and the sides of the BM yoke. I posted this solution on the forum, and Iíll try to find it.

EDIT: I found my post about the remedy.
One thing I noticed with the M1 is that it takes very little pressure to hold steady and then you can easily manually adjust your M1 up or down and it will stay in place. I am not sure how the blendmount setup works though since I use the factory mount.
__________________
I use the following Escort Products

Escort Redline EX
Max360c with wifi
M1 Dash cam with both detectors
Escort Live
ZR5 Shifters
------------------------------------------------------------
Reply With Quote
  #55  
Old 1 Week Ago
mangombia mangombia is offline
Junior Member
 
Join Date: Oct 2017
Posts: 3
Default Blinking Green/Red LED & occasional beep

This morning I was leaving home w/my M1 running and I noted the LED was blinking red/green, and then occasionally beep. It did this for a while and then just blinked green, then went back to red/green. When I got to some traffic to check my iPhone I was able to note it was WiFi connected to the M1, and when I pulled up the M1 app, it displayed the image in front of my car. Later, after a stop and 1hr meeting, I did not note the red/green blinking, although occasionally I still note the beep tone while driving. What is or was going on?
Reply With Quote
  #56  
Old 4 Days Ago
Earthmover Earthmover is offline
Junior Member
 
Join Date: Apr 2015
Posts: 1
Default blinking red light on M1

The M1 is equipped if you are in an accident or by accident run over a curb it automatically records a segment and stores it. The sensitivity can be adjusted in the App and yours might be set to sensitive? When this happens your hear a beep when it starts and it blinks red then when it stops it beeps again and blinks green.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:12 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.