Escort Radar Forum  

Go Back   Escort Radar Forum > Escort Live! > Escort Live! for iPhone

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old April 9th, 2019
fasttr fasttr is offline
Junior Member
 
Join Date: Apr 2019
Posts: 11
Default One more thing...

When I originally registered my new detector (360) it was registered through the (old) app. When I log on to the web site it does not show that my detector is registered. So I went to register it and the web site responds, that device is already registered. Just adding another clue for escort to troubleshoot this issue.
Reply With Quote
  #12  
Old April 9th, 2019
dj_intrinsic dj_intrinsic is offline
Junior Member
 
Join Date: Apr 2019
Posts: 1
Default

I can't log in either after updating and trying to reset my password multiple times.
Reply With Quote
  #13  
Old April 10th, 2019
fasttr fasttr is offline
Junior Member
 
Join Date: Apr 2019
Posts: 11
Default Login suddenly working

Well guess what this morning I can login to my account! Either Escort fixed the issue or perhaps a database had to be synced.
Reply With Quote
  #14  
Old April 10th, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,973
Default

Please reply here if you continue to not be able to log into Escort Live after updating it.

Thank you
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or you can fill out a repair form and we will contact you.
Reply With Quote
  #15  
Old April 10th, 2019
Nerfe360C Nerfe360C is offline
Member
 
Join Date: Dec 2018
Location: PA
Posts: 49
Default New EL version nice but issue with Car Play

First and for most, Thank you Escort for launching this new apps. I start using this yesterday before coming home from work. This is my first Impression and these are my experience so far.

Goods:
-The Map is finally working and pointing the correct directions.
-The Location is working well
-You now can actually report an actual COPS if its "Stationary or Moving" which is really cool like the Waze.
-The App doesn't shut-down no more like the old one does.

Cons,
-I can not here my Over speed on my 360C ( I turn off my BT on my car so I can either hear it thru my phone or my RD.
-Car play seems keep turning off if I connect my cable data while using the EL apps. (car play will work then disable after a 10 to 15 minutes)
* I thought it was my Lightning Cable but it's not. I tried multiple cable and Multiple car that has the Car play.

But overall, its working fine. And yes People, I am not using my Car play for the EL.. just want to let people know that..EL is not compatible with CAR PLaY.. DUH.. just my CAR play stop working if I use the EL apps on my phone while connecting my phone to my Car play so I can use to cal, read, listen and use my NAV..

Any one there if you guys having same issue on your Car play keep disconnecting to your phone while using the New EL Apps.
__________________
Current:
Max 360c Version 1.8
Active Subscribes: EL and DD
iPhone 6S plus
IOS Version 12.1.4
Carrier: AT&T
Reply With Quote
  #16  
Old April 10th, 2019
Sebehk Sebehk is offline
Junior Member
 
Join Date: Jun 2016
Location: Pueblo West, CO
Posts: 12
Default

Quote:
Originally Posted by EscortRadar View Post
Please reply here if you continue to not be able to log into Escort Live after updating it.

Thank you
The app shows me as logged into Escort Live.

Subscriptions section shows me a thank you for purchasing with next year's expiration.

A few issues still lingering from previous app version:

- I have the Over Speed Limit Alert set for "15 Over" but it keeps reverting back to SPEED LIMIT or another setting.
- I turned off VOICE alerts but occasionally still get a voice alert.
- After plugging my iPhone XR for CarPlay, the app will sometimes interrupt CarPlay, almost like a voice alert is coming in.

--->Robert
8-)
Reply With Quote
  #17  
Old April 10th, 2019
fasttr fasttr is offline
Junior Member
 
Join Date: Apr 2019
Posts: 11
Default

Quote:
Originally Posted by EscortRadar View Post
Please reply here if you continue to not be able to log into Escort Live after updating it.

Thank you
Okay, i can log in this morning however i just drove and the speed limit is not displaying. When i tap the speed limit icon i get thanks for purchasing an escort live premium subscription. Your subscription expires 4/8/2020. However when i try and setup community radar alerts i get “to enable please activate a premium subscription through the subscriptions page”. When i go to the subscriptions page i get the thanks for purchasing an escort live premium subscription. Your subscription expires 4/8/2020 message again. Speed limits displayed correctly before the app upgrade.
Reply With Quote
  #18  
Old April 10th, 2019
fasttr fasttr is offline
Junior Member
 
Join Date: Apr 2019
Posts: 11
Default

Quote:
Originally Posted by Nerfe360C View Post


Any one there if you guys having same issue on your Car play keep disconnecting to your phone while using the New EL Apps.
No issue here but i have wireless CarPlay so no cable connection.
Reply With Quote
  #19  
Old April 10th, 2019
Datsun Datsun is offline
Junior Member
 
Join Date: Jun 2011
Location: Alberta, Canada
Posts: 12
Default

I sent an email to customer support about not being able to login with the new version of Escort Live. I constantly get the Invalid username / password combination error.
Customer support responded promptly. Their answer was to wait and try again later.
My guess is that the new servers need time to sync with all the changes.
I hope it doesn't take too long.
Cheers,
Datsun

Later Today...I tried my old logon email address, everything works AOK.
Now, I just have to get my email address updated. Shouldn't be to difficult.
__________________
Max 360, RedLine EX, Escort Live
iPhone 6s

Last edited by Datsun; April 10th, 2019 at 06:17 PM. Reason: Update progress
Reply With Quote
  #20  
Old April 10th, 2019
Nerfe360C Nerfe360C is offline
Member
 
Join Date: Dec 2018
Location: PA
Posts: 49
Default Car Play

Quote:
Originally Posted by fasttr View Post
No issue here but i have wireless CarPlay so no cable connection.
Nice to hear that Bro.. I guess Escort didn't think about the Car play that needs a Cable to able to use it to your Car.... Hope Escort fix this issue and make another quick firmware update.
__________________
Current:
Max 360c Version 1.8
Active Subscribes: EL and DD
iPhone 6S plus
IOS Version 12.1.4
Carrier: AT&T
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:28 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.