Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 1 Week Ago
nikesens nikesens is offline
Senior Member
 
Join Date: Aug 2012
Posts: 116
Default

Quote:
Originally Posted by julioengineer1 View Post
I just got my MAX360 today that I purchased direct from Escort. It is an 85xxx serial number series so I am assuming it comes with the 1.2 firmware. As soon as it connected with Detector Tools it told me that there is an update available which I am assuming is the 1.3. Should I hold off on this update until the issues that are mentioned on the forum get resolved? I wouldn't want to "break" my new RD before I ever use it.
If I was you I would hold off unTIL they get some of the issues sorted out.
Reply With Quote
  #12  
Old 1 Week Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 14,916
Default

Update it.

The nature of internet forums is that you are mostly only going to see reports of issues reported in them. Not many people join a company's customer service forum to report that everything works well (although we do have many doing this).

We are looking into the issues being reported. They appear to be isolated to these particular units.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #13  
Old 1 Week Ago
Flywheel's Avatar
Flywheel Flywheel is offline
Member
 
Join Date: Nov 2015
Location: Austin, TX
Posts: 36
Default

I held off for a while and finally updated last week since I have my Max2 to fall back on.

In my limited experience, there is not much of a difference in performance.

I have not had the lock-up issue. I have passed a number of LEOs and it seems to pick them up with plenty of time.

I have reviewed all the forums and it appears that the independent testing is going ok.

The only thing I see missing in this update - is the tremendous positive feedback and endorsements from some of the superusers. I think initially there was some doubts about the update as far as performance goes, but that seems to have been proven out that there is little performance difference. The filtering seems to work fine.

The only thing I worry about is the "sleepiness" of the detector. I have read some reports where it goes from quiet to full when it is an obvious C/O situation.

The reports of the lockup - well - I have seen my Max2 lockup before....I am not too worried as I have not seen this yet on mine.

The issue with Auto - well - I have never used Auto.

I think the only thing I have seen since the release of the new rev, is the overall enthusiasm on this forum of the product and the new filtering.

I bought the unit to drive with, not troubleshoot, but I rely on the forums to see he interaction between the superusers and the company and see how that real0time feedback is incorporated into future updates.

frequent updates are key, and I think a lot of folks were really put off but the long wait for the IVT rev and then underwhelmed by what seemed to be glitches and performance reductions initially.

I would update it at this time as there do not appear to be any HUGE GLARING issues and I am not expecting an update anytime soon, unfortunately.

Updates are what keeps the superusers engaged and keep the product on top. If there are no updates, independent testing stops and people move on to focus on whatever else new has come out. Even an update to tweak the Auto mode or the sensitivity would go a LOOONG way to show that there is continuous work being done to improve the product and listen to the customers.

Go ahead and update it.
__________________
Max 2
Max 360
Waze
Reply With Quote
  #14  
Old 1 Week Ago
Flywheel's Avatar
Flywheel Flywheel is offline
Member
 
Join Date: Nov 2015
Location: Austin, TX
Posts: 36
Default

Quote:
Originally Posted by nikesens View Post
It is a radar box that issues tickets, no the detector didnít store it because itís not always in the same location. The reason I havenít got back to you with a picture because I havenít been on town or around to get a pic when itís setup.
I would send yours back and be done with it. Not sure if you get feedback if they adjust anything, but if it is not triggering and it was before, then they should take a look at it. Maybe they have to adjust their tolerances to the new firmware or something.
__________________
Max 2
Max 360
Waze
Reply With Quote
  #15  
Old 1 Week Ago
nikesens nikesens is offline
Senior Member
 
Join Date: Aug 2012
Posts: 116
Default

Quote:
Originally Posted by Flywheel View Post
I would send yours back and be done with it. Not sure if you get feedback if they adjust anything, but if it is not triggering and it was before, then they should take a look at it. Maybe they have to adjust their tolerances to the new firmware or something.
Send it back eh? Are you going to pay for me to send it to escort since I have to send it to the USA from Canada. All I need is for escort to give me the go ahead and contact visions electronics in Canada and Iíll gladly return it and get a new 1. And since your following Escort letís get this done if this is what you feel is the right thing to do as well. I know unless visions is contacted with some proof of this they wonít just return it cause escort did something to stop it from seeing this certain photo radar box that it use to see before the 1.6 update. Or escort send me a new unit and Iíll send this lemon back to them when i receive the new one.
Reply With Quote
  #16  
Old 1 Week Ago
TBNTX's Avatar
TBNTX TBNTX is online now
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 5,822
Default

Quote:
Originally Posted by nikesens View Post
Send it back eh? Are you going to pay for me to send it to escort since I have to send it to the USA from Canada. All I need is for escort to give me the go ahead and contact visions electronics in Canada and Iíll gladly return it and get a new 1. And since your following Escort letís get this done if this is what you feel is the right thing to do as well. I know unless visions is contacted with some proof of this they wonít just return it cause escort did something to stop it from seeing this certain photo radar box that it use to see before the 1.6 update. Or escort send me a new unit and Iíll send this lemon back to them when i receive the new one.
Send it back to the Dealer in Canada from which it was purchased. Escort in the USA has relationships with its Canadian resellers.
__________________


Countermeasures:

Radar Detectors: Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)
Reply With Quote
  #17  
Old 1 Week Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 14,916
Default

Quote:
Originally Posted by nikesens View Post
Send it back eh? Are you going to pay for me to send it to escort since I have to send it to the USA from Canada. All I need is for escort to give me the go ahead and contact visions electronics in Canada and Iíll gladly return it and get a new 1. And since your following Escort letís get this done if this is what you feel is the right thing to do as well. I know unless visions is contacted with some proof of this they wonít just return it cause escort did something to stop it from seeing this certain photo radar box that it use to see before the 1.6 update. Or escort send me a new unit and Iíll send this lemon back to them when i receive the new one.
As I've asked before in your other posts, I need more information about this "photo radar box". Please check your private messages.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #18  
Old 1 Week Ago
BagNDrag's Avatar
BagNDrag BagNDrag is online now
Senior Member
 
Join Date: Jan 2012
Location: Salt Lake City, Ut
Posts: 491
Default

Quote:
Originally Posted by EscortRadar View Post
Update it.

The nature of internet forums is that you are mostly only going to see reports of issues reported in them. Not many people join a company's customer service forum to report that everything works well (although we do have many doing this).

We are looking into the issues being reported. They appear to be isolated to these particular units.
Hi ER,

Just curious if you have been able to reproduce the issue with those particular units? Thanks in advance.

-Mark
__________________
- 2004 Mustang Cobra Conv - 530 bhp 536 tq
- Max 360 - Software Version 1.6
- Carbon Fiber Passport Max - Software Version 1.11
- Passport - 1/3/4 ON / RDR Off - Software Version 1.4
- Redline - 2/5/6/8 ON / RDR Off
- Passport SC55 (Redline Savvy and Dual Display)!
- Wife - Max 360 - Software Version 1.6
- Escort Live 2.1.18 - iPhone 7 Plus - iOS 11


Past CMs
- 9500ix Race Edition (Sold)
- 9500ix Blue (Sold)
- 2 V1s (Sold)
- Various Uniden / Whistler in the past
Reply With Quote
  #19  
Old 1 Week Ago
nikesens nikesens is offline
Senior Member
 
Join Date: Aug 2012
Posts: 116
Default

Quote:
Originally Posted by EscortRadar View Post
As I've asked before in your other posts, I need more information about this "photo radar box". Please check your private messages.
I have checked my private message and replied. Thanks will wait for you to reply back.
Reply With Quote
  #20  
Old 1 Week Ago
nikesens nikesens is offline
Senior Member
 
Join Date: Aug 2012
Posts: 116
Default

Quote:
Originally Posted by TBNTX View Post
Send it back to the Dealer in Canada from which it was purchased. Escort in the USA has relationships with its Canadian resellers.
Thanks for your reply and I understand what you are saying but where I bought it they won’t just replace it because it won’t pick this photo box. My first unit I had the grey paint was coming off of the buttons and I had a heck of a time getting them to replace it. The dealer finally made a call to escort rep and after spending 2 hours in the store they finally replaced it. I have replied to escorts private message so hopefully we can get this figured out. As always I do appreciate the replies. Thanks
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright © 2017 Escort Inc.