Escort Radar Forum  

Go Back   Escort Radar Forum > News > Escort Radar Announcements

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old October 11th, 2017
theozee theozee is offline
Junior Member
 
Join Date: Oct 2017
Posts: 5
Default

Another quick question for you guys, have you noticed the 1.6 update making a difference on anti-falsing/blind spot on other cars? I'm hoping there's a noticeable difference. Ours goes off alot on Acura's, Honda's etc.

Thanks again
Reply With Quote
  #12  
Old October 12th, 2017
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 15,791
Thumbs up You guys rock!

Thanks for helping out theozee! Glad to hear that you all got it figured out.

Quote:
Originally Posted by theozee View Post
Another quick question for you guys, have you noticed the 1.6 update making a difference on anti-falsing/blind spot on other cars? I'm hoping there's a noticeable difference. Ours goes off alot on Acura's, Honda's etc.

Thanks again
You will definitely notice a difference. Some vehicles will still cause alerts but these are far fewer and farther between.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #13  
Old October 15th, 2017
RT0870 RT0870 is offline
Junior Member
 
Join Date: Aug 2016
Location: Beckley, WV
Posts: 5
Default

Updated and everything appears to be working fine......except.....every time I log in, it says my subscription has expired.

I paid for my annual subscription on 3/22/17.

Any ideas?
Reply With Quote
  #14  
Old October 15th, 2017
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,192
Default

Quote:
Originally Posted by RT0870 View Post
Updated and everything appears to be working fine......except.....every time I log in, it says my subscription has expired.

I paid for my annual subscription on 3/22/17.

Any ideas?
I presume that you're referring to Defender, and not Escort Live.

PM EscortRadar directly. Tell him what's happening and provide him with your username for EL and the serial number of your detector. He can look into the subscription database.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)
Reply With Quote
  #15  
Old October 15th, 2017
RT0870 RT0870 is offline
Junior Member
 
Join Date: Aug 2016
Location: Beckley, WV
Posts: 5
Default

That would be a correct assumption. I will contact them tomorrow morning.

Thanks!
Reply With Quote
  #16  
Old October 15th, 2017
TTOK TTOK is offline
Junior Member
 
Join Date: Oct 2017
Location: OKC
Posts: 3
Default

Any idea when the update for Mac will be available?
Reply With Quote
  #17  
Old October 25th, 2017
LarriB LarriB is offline
Junior Member
 
Join Date: Aug 2012
Posts: 7
Default

Quote:
Originally Posted by TTOK View Post
Any idea when the update for Mac will be available?
Ditto on this. A PC upgrade doesn't help a lot of us. Especially, since those who are affected by the Apple iOS11 problem are more likely to be using an Apple Mac computer.

Last edited by LarriB; October 25th, 2017 at 01:13 PM.
Reply With Quote
  #18  
Old November 1st, 2017
mattcslack mattcslack is offline
Junior Member
 
Join Date: Nov 2017
Location: LA, the other one.
Posts: 5
Default

My max2 stopped appearing in IOS BlueTooth the moment 11.x appeared on my phone. Even after removing max2 from BT, it rarely only appears momentarily and then doesn't connect.

Escort support walked me through the rather painful updating process.
(had to complete it 3x to get it right, even though escort software indicated success each time). Escort support confirmed I'm on 1.7.

Still doesn't show up in IOS.
Updated to 11.1
Max2 still does not appear in IOS BT, or in Escort app.

Escort proposed my hardware is bad and time to $upgrade$. Basic Logic dictates otherwise.

Anyone know an option to try given max isn't even appearing in BT?

and Yes, I've tried every re-boot cycle, open/close app, BT sequence known to man...while tech support was on the line.

First time poster, apologies if I did this wrong.

-Matt
__________________
Speeding is simply faster.
Reply With Quote
  #19  
Old November 1st, 2017
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,192
Default

From my own experience, the iOS update broke several Bluetooth-related products. Not just Escort's. Anybody can do a Google search and read the same things.

After updating to the new firmware for my Max 2 and Max 360, everything is working as expected. And if you've read thru this thread, it appears that it's working for almost everyone else, too.

Asking this: Did you use the Windows version of DT to install the firmware? I didn't read in you post what platform was used. If not, please review the opening post. The updated firmware can only be installed by the Windows version of Detector Tools (for now).

If you did use the Windows version, then I suspect that your detector might, indeed, have a hardware problem. But if you used the macOS version of DT, it hasn't been updated yet to support new firmware. A macOS update to DT is forthcoming, but it's not available right now.

I hope that this helps. Say more when you are able.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)

Last edited by TBNTX; November 1st, 2017 at 11:55 PM.
Reply With Quote
  #20  
Old November 2nd, 2017
mattcslack mattcslack is offline
Junior Member
 
Join Date: Nov 2017
Location: LA, the other one.
Posts: 5
Default

Yes, I used windows.

I have had other BT issues, but I believe all BT is now working except for Escort.

I will re-check that all BT items are working.
I will use an alternate IOS phone to connect.

Can you explain how it can be a HW issue when it was working fine right up until the moment I deployed IOS11? Genuine question, no attitude.

Thanks.
__________________
Speeding is simply faster.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:40 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.