Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX II and MAX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 4 Weeks Ago
14.4volts 14.4volts is offline
Junior Member
 
Join Date: Oct 2018
Posts: 2
Question Max 2 serial 67 no BT wonít update 😑

Hey all, as the title states I have a Max 2 that is not discoverable by either my iPhone 7 IOS 11.4.1 or my Samsung galaxy mega, I havenít put the live app on the mega.. itís my understanding that it isnít required with this generation Max 2 to see it.
Hereís where Iíve been so far, besides hours of reading on here.
The detector says it has master V1.9 on it.
Iíve tried both DTP and DT on both a Windows 10 and Windows 7 machine, multiple usb cables and different ports.
Installed with and without the drivers, update all and update functions.
All end with software(s) failed to up date or update failed.
They go through the whole entire process until the last step.
If using DT it gets to step 5, gets all the way through it and then gives me the error.
I am/was hoping that the error came from the last update which was years ago, I only tried it once and it was a few months after my purchase, I bought this back in Oct 2016.
I was only able to use BT with live for about 6/7 months after purchase before it stopped working, when I purchased it from the Audio Watt store I thought I was getting the newer version.. the numbers are confusing II/2 and 2 when mine clearly has II on it but itís actually a 2? 😂👌 I donít know.
I do temper trying to update it once and I think I got the exact same error and gave up. Being that itís V1.9.. I donít know if I got that then or if itís only taken a partial update the times I tried it.
I didnít check the firmware version before attempting these last updates.
DT ask ďyour software is current are you sure you want to updateĒ DTP doesnít say anything, both attempt the update.

So I donít know if my intial update long ago caused the BT portion to fail or if the chip itself died, I do know it happened while it was still in warranty and sadly it is no longer.

Has anyone experienced this?
Also, my last ditch effort would be to try rolling everything back on it to older Firmware/software seeing if that fixes it and then trying to update it again.
Reall bumbed about this, any advice or direction here would be appreciated.
Thanks!
Reply With Quote
  #2  
Old 4 Weeks Ago
Darkmand26 Darkmand26 is offline
Junior Member
 
Join Date: Oct 2018
Posts: 1
Default

Im Having the exact same problem, except i can connect to my phone and escort live. Sometimes it takes 20 times "no exaggeration" to connect but eventually it does. Sometimes it automatically connects. Don't know why. The detector says it has master V1.9 on it. Have tried 2 computers. Windows 7,8, and 10. Detector tools pro and regular. No dice it will not update. Goes all the way through the update and says failed. If i try to update all same thing gets all the way through and fails. shows writing and erasing but will not update. Updating it as i speak and After doing update all it says update failed to complete. BUT even after all the erasing and writing It still stays on 1.9. The detector still works. Just wont update. So if you find an answer please let me know. Also have a serial 67.
Reply With Quote
  #3  
Old 4 Weeks Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,305
Default

If it is failing on step 5 then the bluetooth chip is malfunctioning which explains why the phones are not seeing them. The detectors will need to be serviced. To set this up, contact our service department at the number in my signature below.

Thank you
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #4  
Old 4 Weeks Ago
14.4volts 14.4volts is offline
Junior Member
 
Join Date: Oct 2018
Posts: 2
Default

Quote:
Originally Posted by EscortRadar View Post
If it is failing on step 5 then the bluetooth chip is malfunctioning which explains why the phones are not seeing them. The detectors will need to be serviced. To set this up, contact our service department at the number in my signature below.

Thank you
I did today, got everything setup.
Not very happy about it, while this did happen under warranty and I realize I should have dealt with it then... I assumed that it was an issue with the one and only update I tried a few months after I bought it.
Some time after Oct 2016
I know it worked up until that point, I’ve recalled when, how and where.
I remember getting an error to the update and the live portion not working after.
I know it worked up until that point.
I wasn’t using it much or at all at the time because the functionality between it and my other BT devices was annoying.
When it didn’t work after... I just figured I’d get to it later because I wasn’t using the live app often enough and besides making changes to the detector it wasn’t that important to me. (Had other devices in other cars I was driving)
That said, it was either a point where escort had issues with how/what it was updating at the time or the chipset you’re/were using for BT was not stable.
Not really happy about having to pay to send it back.
That said, I feel a little short changed that your software isn’t a little more advanced in this.
I was hopping to be able to try and roll it back to stock firmware just to see.
The fact that these fail more frequently then they should... things should be looked at.
The live app and the BT was a spur decsision for me, it seemed awesome and offered more then the others. I bought it because of that, wanted to check it out.
I’ll give you something else, I’ve installed ci 360’s, I can buy them and all of your products through my distributor.
I can buy direct from *** and have done tons of their undetectables over the years, I’ve installed both your product and theirs in everything from pathfinders to Ferrari etc.
I’ve never had these problems with defective parts getting replaced/repaired or the amount of weirdness I feel reading your forums when it comes to what’s actually going on... bad firmware, updates and the overall uneven but oddly normal conformity you have with it.
It feels to me like the same reason I don’t update my phone software until I absolutely have too, bugs aren’t worked out and I end up being the gieany pig.
Far as what I’ve read here, even though this is my first post... I don’t have much confidence in this being a defective chip. More I feel that whatever escort was trying to implement at the tine is the cause.
I’ve seen several examples of it here on the forums by research, the multiple times escort has updated v1.9 or other realizes that in certain situations caused problems with peoples detectors.
Not bashing, I bought this unit for the very reason of using it and having an opinion about it.
Btw... the laser portion is meh.. it falses way more then it doesn’t.
Ask me about my 101mph ticket in my M3.
That said, really.. if it goes off.. all it tells you is you’re going to get a ticket.
I’ve been confused about that from day one, what’s the point?
I didn’t buy it for laser because it doesn’t do anything, I was curious to see what it picked up though... only falses. I’ve never had an accurate true hit with it.
I get that though and it’s just a side note. ��
Others do it too, I find it a gimmick. You either need multiple shifters/diffusers or you’ll get hit with laser and you’ll get a ticket, even then distance and what the officer is aiming at has a huge thing to do with it working and not.. also the drivers speed and response time to slow down before the officer finds another point on your car to shoot at.
Still, I really think that there are a couple issues here that I shouldn’t have to pay for, not to mention the fact that nothing is really spelled out.
Drivers/no drivers, what updates to have and not.. etc.
I’ve installed plenty, I’ve never left my customers in the dark with these things nor made them figure it out. Because they won’t, they don’t have the time or the savy to be bothered by it.
Escorts updates should come in the form of ONE program and ONE only, they shouldn’t have to know what windows version they are using or what device they are plugging in.
The reality is it leaves a lot to be determined or open for argument/mistakes or a overall dissatisfaction of what could otherwise be a great product.
I am sure (after reading 100s of posts) I am not the only one that feels this way.

I think someone needs to get on board with some responsibility here and reconnaissance is necessary to deliver a better product, especially if your product needs update after its retail packaging.

These Max units seem like a failed experiment, honestly the only thing that still has me digging it is the live app, I like the way it should work.. like waze or similar community real time environments. It’s why I bought it and sadly it doesn’t work as it should.

Sorry for the long winded post but I am not really, the extra cash I’ll spend to get this fixed just means I could have gotten a 360.. at the time had terrible reviews for the same reason this did later... see where I am going?
The inconsistency in cross platform operation is always going to be a dissadvatage to people who are power users.
It’s only a disadvantage to those that sell your product on retail/install side when the software doesn’t work right at the time of sale.
After that most of these end users don’t do anything with it, most don’t even know or remember they can.
Even then.. when they have a problem, who do you think they’d call first.

Wanting to chualk this all up to chip failure for me seems suspect, especially when escorts software has to update in a block and not by pieces.. or at least there is no clarity on what it or how it does anything.
The multiple choice for software... ��*♀️�� too much.

While I appreciate your help, having to post this, not having anything to find seems like a waste of time.
I did read a post where when it stops at update 4 it was Bluetooth, then the guy was able to make it work..
now it’s update 5 and it’s the same response, it gives me no confidence.

Sorry for all the typos or anything else, tiny screen land on my iPhone.

Last edited by EscortRadar; 3 Weeks Ago at 12:53 PM. Reason: removed mention of non-Escort product
Reply With Quote
  #5  
Old 3 Weeks Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,305
Default

Step 4 on a Mac computer is bluetooth, while step 5 on a Windows PC is bluetooth.

It is normal to mainly hear about issues on a manufacturer's support forum. This is why it exists after all, to support the product. It seems this is why you stopped by, not just to say "hi". Unfortunately it sounds like your detector will need to be serviced.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:29 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.