Escort Radar Forum  

Go Back   Escort Radar Forum > Dash Cameras > M1

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 4 Weeks Ago
Cowboy45 Cowboy45 is offline
Junior Member
 
Join Date: Sep 2020
Posts: 1
Default M1 MAX 360

when I plug my MI in with the power cord the came with my max 360 then plug the M1 into my 360c, my GPS on the 360c starts doing its own thing while I am driving. My speed flashes on and off it wont maintain the correct speed. From reading the thread it sounds like I need a different power cord? Thanks
Reply With Quote
  #2  
Old 4 Weeks Ago
flylow7f39 flylow7f39 is offline
Moderator
 
Join Date: Nov 2010
Posts: 3,784
Default

Moved to it's own thread.
__________________
__________________________________________________ ______________________________________
Moderators here are not Escort employees.

If you need immediate help give Escort Radar customer service a call right after they open at 1-800-543-1608, option 2, available from 9am-5:30pm Eastern Time Mon-Fri. Wait for the pause following the message and use the option for a call back.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:34 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.