Escort Radar Forum  

Go Back   Escort Radar Forum > Escort Live! > Escort Live! General

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 2nd, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,305
Exclamation ESCORT Live is experiencing login issues (new users only)

ESCORT Live is experiencing login issues with some new accounts (accounts that were created in the past few days). We should have this resolved by tomorrow morning. There is nothing that you need to do in order to solve this. Just keep trying to log in using the login information you used when you registered your detector. Once it is resolved, then your login will work.

Thank you for your patience.

UPDATE: the issue is resolved.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat

Last edited by EscortRadar; July 6th, 2018 at 05:12 PM.
Reply With Quote
  #2  
Old July 4th, 2018
bigbrother54 bigbrother54 is offline
Junior Member
 
Join Date: Jan 2018
Posts: 19
Default log in issue

I just got my new Escort Max 360c and have not been able to log into my Escort live app. I have had the max 360 for many years and never had any problems with it but this one has been nothing but problems. Also I keep getting this pop up that says that my subscription needs to be re-newed. Doesn't Escort give you a 1 yr free subscription with the purchase of a ner detector? Also I was told by the support person that I have over a year left on my old subscription that I had with my max 360 what has happened to that remaining subscription?
Reply With Quote
  #3  
Old July 5th, 2018
DesertRatAZ DesertRatAZ is offline
Junior Member
 
Join Date: Feb 2016
Posts: 22
Default Live Data not Showing

I posted this in a different thread, yet the moderator took upon themselves to close my thread and offered nothing that pertained to my problem. My problem is not a login issue. I am able to login just fine to EL. But since, the moderator wants me to post here I will. My problem is:

I have a new Samsung Galaxy S9+running the latest and greatest of EL (2.1.9.4). It has been working fine since last Sunday. However, today, maybe last evening, none of the Live Alerts are showing up on the map. When it detects radar it says that the alert was reported. However, no alerts, mine or others are showing up on the map. Is there an issue going on?

Reportedly there have been issues. To hopefully avoid multiple threads I'm going to close this one.

http://escortradarforum.com/forums/s...ad.php?t=17770

and that folks is Escort Radar's wonderful customer service. Pathetic.
Reply With Quote
  #4  
Old July 5th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,305
Default

Are you logged into your premium Escort Live account? I am seeing Live alerts in my area including ones that I reported.

Our moderators are simply trying to keep the forum organized.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #5  
Old July 5th, 2018
DesertRatAZ DesertRatAZ is offline
Junior Member
 
Join Date: Feb 2016
Posts: 22
Default

Quote:
Originally Posted by EscortRadar View Post
Are you logged into your premium Escort Live account? I am seeing Live alerts in my area including ones that I reported.

Our moderators are simply trying to keep the forum organized.
Yes I am logged in.
Reply With Quote
  #6  
Old July 5th, 2018
DesertRatAZ DesertRatAZ is offline
Junior Member
 
Join Date: Feb 2016
Posts: 22
Default

Quote:
Originally Posted by EscortRadar View Post
Are you logged into your premium Escort Live account? I am seeing Live alerts in my area including ones that I reported.

Our moderators are simply trying to keep the forum organized.
OK I spoke with Customer Service on the phone. They gave me more information. I don't know why the moderators can't do the same? Due to the merging to two different apps, The Escort Live servers are down. The problem has been worked since Monday July 2, 2018. Unfortunately no ETA can be promised at this time. This problem is affecting everything EL. In my case it isn't affecting my login, but it is affecting my Live Alerts from showing up. Hopefully, we'll be back in business soon. This is a bad weekend for Escort Live to have issues when there is so much July 4, 2018 travel going on. But at least we have more information.
Reply With Quote
  #7  
Old July 5th, 2018
IzzyMan12078 IzzyMan12078 is offline
Junior Member
 
Join Date: Aug 2014
Location: NY
Posts: 26
Default

Don't be shocked. The thread I had been waiting for an update too, has been deleted. My logins have not worked for days, and my Max360C which was showing PSL data from the car WIFI connection has had -- for just as long. And before anyone asks - yes the background for the PSL speed sign is White, and my data connection is good as I am streaming music services from the same connection. I have checked my password on the Escort site:
https://www.escortradar.com/register/livepwrecover.php

And the email it sends me has the correct password.

The Max360C was working fine for a month. Yes this is the account the registration email for the Max360C has associated with it

Yet I get Invalid Username/Password upon login.

I wouldn't complain normally, as I haven't ever paid for an EL subscription. I have however paid for a Max360C which is advertised to have features it currently does not, and my three year subscription I did pay for for redlight cameras etc....the clock is ticking.

Based on others, and research, I don't think my issue will straighten itself out when EL logins start working.

How can I have my EL account deleted, recreated, and I can reregister my two radar detectors, the redlight DB subscription etc?
Reply With Quote
  #8  
Old July 5th, 2018
IzzyMan12078 IzzyMan12078 is offline
Junior Member
 
Join Date: Aug 2014
Location: NY
Posts: 26
Default

Quote:
Originally Posted by DesertRatAZ View Post
OK I spoke with Customer Service on the phone. They gave me more information. I don't know why the moderators can't do the same? Due to the merging to two different apps, The Escort Live servers are down. The problem has been worked since Monday July 2, 2018. Unfortunately no ETA can be promised at this time. This problem is affecting everything EL. In my case it isn't affecting my login, but it is affecting my Live Alerts from showing up. Hopefully, we'll be back in business soon. This is a bad weekend for Escort Live to have issues when there is so much July 4, 2018 travel going on. But at least we have more information.
This is the problem with company owned forums. This thread itself was posted three days ago but did not say new users only. It was edited recently to completely change the topic, and minimize the problem. I have been a user since 2014, and my login is failing. I have invested over $1500 in Escort Radar Detectors, and I'm considering abandoning the brand.
Reply With Quote
  #9  
Old July 5th, 2018
wheel366 wheel366 is offline
Member
 
Join Date: Oct 2017
Posts: 32
Default

Quote:
Originally Posted by IzzyMan12078 View Post
This is the problem with company owned forums. This thread itself was posted three days ago but did not say new users only. It was edited recently to completely change the topic, and minimize the problem. I have been a user since 2014, and my login is failing. I have invested over $1500 in Escort Radar Detectors, and I'm considering abandoning the brand.
I had problems logging in multiple days in a row. Finally got logged on but not getting any data from alerts.
Reply With Quote
  #10  
Old July 5th, 2018
Repo.Dave Repo.Dave is offline
Junior Member
 
Join Date: Jul 2018
Location: Mid-West, USA
Posts: 7
Thumbs down "New User's"....

Quote:
Originally Posted by EscortRadar View Post
ESCORT Live is experiencing login issues with some new accounts (accounts that were created in the past few days). We should have this resolved by tomorrow morning. There is nothing that you need to do in order to solve this. Just keep trying to log in using the login information you used when you registered your detector. Once it is resolved, then your login will work.

Thank you for your patience.

Yea, uh that's not correct! I've had an account for years and I'm not able to log in....been this way since the beginning of the week....been told the same thing every time I've called..."we're working on it, should be fixed "soon"." Yea, uh, what's really going on here bc I rely on the app along with my unit on a daily basis.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:51 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.