Escort Radar Forum  

Go Back   Escort Radar Forum > News > Escort Radar Announcements

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old October 11th, 2017
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,305
Exclamation Update available to resolve iOS 11 connection issues

A software update is available from Detector Tools for Windows for the following devices to resolve bluetooth connection issues with iOS 11:

Max 360, only with serial number beginning with 79
Passport
Max 2
SmartCord Live for iPhone and Android
SmartCord Live Direct Wire for iPhone and Android
SmartCord Live Direct Wire 9500ci for iPhone and Android

Note: the Mac version of Detector Tools will not install this update
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat

Last edited by EscortRadar; October 12th, 2017 at 02:15 PM. Reason: Added: Mac Tools will not install update
Reply With Quote
  #2  
Old October 11th, 2017
theozee theozee is offline
Junior Member
 
Join Date: Oct 2017
Posts: 5
Default I'm hopeful but....

I just reinstalled the detector tools program on my computer from Escort Website. My serial number does start with 79, (I bought 2 new Max360's when they came out) currently running 1.5, and my apple phone doesn't see the max360? I called customer service at Escort, told me to run an update. My computer is only 3 years old, updates with defender database with no problem, but when I try to update the software, I get 2 messages, one is "Unable to verify interface settings," and the other is "Error updating Max360."

I need help? I was hoping this new patch would allow me to get connected again. BTW, when in car with Escort Live open, I see myself moving on map, but my phone says "no radar detector connected." If I hit devices underneath, nothing comes up. Worked a couple months ago, but not now?

I hope my post makes sense to Escort.
Reply With Quote
  #3  
Old October 11th, 2017
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,304
Default

Quote:
Originally Posted by theozee View Post
I just reinstalled the detector tools program on my computer from Escort Website. My serial number does start with 79, (I bought 2 new Max360's when they came out) currently running 1.5, and my apple phone doesn't see the max360? I called customer service at Escort, told me to run an update. My computer is only 3 years old, updates with defender database with no problem, but when I try to update the software, I get 2 messages, one is "Unable to verify interface settings," and the other is "Error updating Max360."

I need help? I was hoping this new patch would allow me to get connected again. BTW, when in car with Escort Live open, I see myself moving on map, but my phone says "no radar detector connected." If I hit devices underneath, nothing comes up. Worked a couple months ago, but not now?

I hope my post makes sense to Escort.
Hi theozee -

The updates work for me on my Max 360 and my Max II. Let me ask a couple of questions:
  • What version of DT are you using?
  • For which platform (macOS or Windows)?
  • How did you perform the update? Were you using the big green button on the main screen, or:
    • Using the "Update All" option (Windows version under the "Advanced" tab?
    • Using the "Update Firmware" under the "Manual Updates" tab in the Mac version?
  • Did you power-cycle the Detector to finalize the firmware update?

The devil is in the details but I can confirm that the new firmware updates are working.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)

Last edited by TBNTX; October 11th, 2017 at 07:22 PM.
Reply With Quote
  #4  
Old October 11th, 2017
theozee theozee is offline
Junior Member
 
Join Date: Oct 2017
Posts: 5
Default

Hi TBNTX
First, thank you for trying to help me.
I have an Acer desktop, Windows 10, Intel core i5-4440 CPU 3.10 GHZ, 8.0 GB 64 bit operating system.
I uninstalled the "detector tools" on my computer, restarted it and downloaded the latest detector tools from Escorts website. I restarted it again. After I open detector tools, it says no detector detected, so I plug in the USB cord into the computer, then attach the other end into my Max360. That's when I get the first message, "Unable to verify interface settings." Then I click OK, and the screen comes up with the 2 green lights on "Merge your data..." and "Update your......software from Escort."
If I click Merge your data, it says it works by saying "Successfully Merged Database locations...."

The problem happens when I click the lower green light button for software update. First when I click it, it says I'm currently up to date, but its 1.5, I think there's a 1.6??? If I say I still want to update the software, I get the Error message. It says, "Error updating your Max360." I click OK.

Then I go to "advanced options" tab to click "Update All" It tries by saying its downloading 1 of 5, but then unfortunately, I then get the same "Error updating your Max360."

Since my computer is relatively new, I hope I don't have to buy a new one to update my Max 360. I hope that answers your questions. Thank you for taking the time to try and help me. I appreciate it!

BTW, I also run Webroot Secure Anywhere software to protect my computer. When installing detector tools, I say yes t trusting Escorts detector tools to load onto my computer.
Reply With Quote
  #5  
Old October 11th, 2017
richie_redbull richie_redbull is offline
Senior Member
 
Join Date: Dec 2012
Location: Westbank, British Columbia
Posts: 115
Default

Quote:
Originally Posted by theozee View Post
The problem happens when I click the lower green light button for software update. First when I click it, it says I'm currently up to date, but its 1.5, I think there's a 1.6??? If I say I still want to update the software, I get the Error message. It says, "Error updating your Max360." I click OK.

Then I go to "advanced options" tab to click "Update All" It tries by saying its downloading 1 of 5, but then unfortunately, I then get the same "Error updating your Max360."
Hi theozee,

I had the same issue. I tried updating, first with my Mac, my Mac can't see my Smartcord DW2 via Detector Tools at all. My Windows 10 Laptop can. But I also kept getting "Error updating your smarcord", I had to keep disconnecting it from usb 3 times by unplugging it, till it finally took. I'm sure there are some bugs still to be worked out with Detector Tools for both Mac and PC. However after the 3rd time it did update, and when I then put it back in my car and tried it. My smart cord live dw2 connected to bluetooth faster than it ever has in the past. So it worked and seems to work well... I have no idea what the firmware did, but THANK YOU Escort for fixing it... Anyway theozee, have you tried just doing the unplug plug it back in thing? Just curious.. but it only worked on the PC, the MAC still can't see it...

Mac Running High Sierra
PC Running Windows 10
iPhone 7 Plus with iOS 11.0.3
Reply With Quote
  #6  
Old October 11th, 2017
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,304
Default

Quote:
Originally Posted by theozee View Post
The problem happens when I click the lower green light button for software update. First when I click it, it says I'm currently up to date, but its 1.5, I think there's a 1.6??? If I say I still want to update the software, I get the Error message. It says, "Error updating your Max360." I click OK.

Then I go to "advanced options" tab to click "Update All" It tries by saying its downloading 1 of 5, but then unfortunately, I then get the same "Error updating your Max360."

Since my computer is relatively new, I hope I don't have to buy a new one to update my Max 360. I hope that answers your questions. Thank you for taking the time to try and help me. I appreciate it!

BTW, I also run Webroot Secure Anywhere software to protect my computer. When installing detector tools, I say yes t trusting Escorts detector tools to load onto my computer.
I use Webroot, too when running Windows.

Try this for me.

Disconnect everything and restart your Acer. Perform any system updates required for Windows and your installed software.

Once you've done this, connect your detector directly, without launching DT. Your system will find the latest drivers and install them. Be patient. This usually happens in the background. Give it ten minutes or so.

Next, disconnect the USB cable from your Acer, and then re-connect it after fifteen seconds or so. Let your Acer re-discover the detector.

Now, launch DT. Once it finds your detector, go to the Advanced tab and select "Update All".

I think that this will result in a successful firmware update. If you see any error messages, please post them here.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)
Reply With Quote
  #7  
Old October 11th, 2017
theozee theozee is offline
Junior Member
 
Join Date: Oct 2017
Posts: 5
Default

Hi Richie-Redbull.
I tried unplugging a few times, and trying the software update, I powered down the Max360, the powered it back up holding down the mark and mute button, I still have 1.5 installed on Max360 and I keep getting the error message. I'll try again before I go to bed and again in the morning before work.

Strange that the database merge is fine, but not the software part!?!?

I am using the AC/DC power cord and Smartcord, purchased both from Escort.

Thank you for your input/advice
Reply With Quote
  #8  
Old October 11th, 2017
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,304
Default

Quote:
Originally Posted by theozee View Post
I am using the AC/DC power cord and Smartcord, purchased both from Escort.
That's the issue, theozee.

External power shouldn't be used when using Detector Tools. When updating firmware, only a USB data cable should be used. DO NOT USE THE POWER CABLE.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
LIDAR Defense: Escort LSP + Veil G4
Phone: Apple iPhone 6s (128 GB) + AT&T
CB: Midland 75-822
HAM: Yaesu FT-7900R, Baofeng UV-5R, UV-3R
Scanner: GRE PSR-500 (Triple-trunking)
GPS: iPhone 6s with GPS Plus and Waze
Dashcam: Thinkware F750 (backup: DOD LS430W)
Reply With Quote
  #9  
Old October 11th, 2017
flylow7f39 flylow7f39 is offline
Moderator
 
Join Date: Nov 2010
Posts: 3,123
Default

Quote:
Originally Posted by theozee View Post
I am using the AC/DC power cord and Smartcord, purchased both from Escort.
Just use a USB data cable, don't use 12 volt power. No external power required, the USB cable provides the needed power.

Last edited by flylow7f39; October 11th, 2017 at 09:15 PM.
Reply With Quote
  #10  
Old October 11th, 2017
theozee theozee is offline
Junior Member
 
Join Date: Oct 2017
Posts: 5
Default

Hi TBNTX and all others!!
THANK YOU!!!!! You did it! It works, both detectors are updated to 1.6 and work now. Both work with our iphones. I had no idea that you weren't supposed to use the smart cord to power the detector as you ran the update. How did I miss this?

I did follow all of your instructions TBNTX, I rebooted computer, while updating Windows 10, then I had to pick up my girls from soccer and dance classes and get them to bed, but after getting home and running the update with your directions, I can't tell you how happy I am that I don't have to send these back into Escort.

Cheers to you and everyone else, Thanks again!

Ted
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:58 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.