Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360c

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old November 5th, 2020
MajorTom MajorTom is offline
Junior Member
 
Join Date: Nov 2020
Posts: 3
Default This May Help If You Are Having Trouble With GPS &/or False Laser Alerts

Hi…new member here. This drove me nuts. New 360c [4 days old] & New BlendMount. Installed both in my vehicle and went for test drive. First noticed that the GPS was not working then after about 2 minutes the detector said GPS signal acquired but the numbers were all wrong. I was driving about 40mph and they read anywhere from 0 to 85. Then it said GPS signal lost, it kept alternating on and off. Then after another minute or so the laser alert went off. It was false. Kept doing this all the way back home. So what could it be, defective detector or something else.

Turns out I have a vehicle with an “Intelligent” rear view mirror console. It has auto-dimming, a front & rear camera and On-Star. With the BlendMount mounted it was a tight squeeze to install the detector underneath. Decided to test a theory…used the suction mount supplied and mounted it 3 or 4 inches away from the console. Went out for another test drive, BOOM !!! The detector started to work as expected. GPS locked up in about 30 seconds and stayed locked on for the half hour drive with the correct speed & did not get any laser alerts either. So evidently there is a lot of RF leaking out of the console. So I guess I am stuck with using the suction cup mount until I get a new car.
Reply With Quote
  #2  
Old November 5th, 2020
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,897
Default

Glad you found the issue!
Upon start-up the detector does not announce when it first acquires GPS lock. It only announces either that it has lost its initial GPS signal or that it has been re-acquired after having lost it. The suction cup mount is the best Escort has made to date. Too bad about the mirror electronics interference.
Reply With Quote
  #3  
Old November 10th, 2020
Bigdog9586 Bigdog9586 is offline
Senior Member
 
Join Date: Jan 2015
Posts: 104
Default

I have a Cadillac XT5 with mirror you describe and a new Tahoe with the updated version of that mirror. Both work great from the suction cup mount.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:21 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.