Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360c

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 3 Weeks Ago
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 15,602
Default

Quote:
Originally Posted by er95 View Post
Thanks! Iíll give that a try.

Iím also having WiFi issues. But I read in another thread that Escort customer service told a customer that thereís a known issue with WiFi thatís currently being worked on. Iíll sit tight until then. Hopefully itíll fix my issue too.
Please start a new thread about the Wi-Fi issue when you have time. I'd like to know about it.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #22  
Old 1 Week Ago
Yldcherry Yldcherry is offline
Junior Member
 
Join Date: Feb 2012
Posts: 10
Default

Mine locked up for the first time since I bought it a few months ago. I don't use Live so no Live or Bluetooth connection to the detector. Locked on 2 K signals. Still displayed vehicle speed correctly.
Reply With Quote
  #23  
Old 1 Week Ago
Stoopstroop Stoopstroop is offline
Member
 
Join Date: Jan 2017
Posts: 88
Default

That is the main problem for me. Unless you watch the detector every second you can be driving around unprotected and not even know it. This is a VERY serious issue. One would think it would take precedence to be fixed over just about anything else.

Almost 2 months now and no fix in site.
Reply With Quote
  #24  
Old 1 Week Ago
CharliesTheMan CharliesTheMan is offline
Junior Member
 
Join Date: Apr 2018
Posts: 5
Default

I've noticed that my lock-ups are occurring on a speed trap alert often. The strange thing is, it's locked up twice on me going in the same direction (at least two or three times) but coming back, it doesn't always do it in that spot.

It seems to be when I'm approaching something like a speed trap, and it's on the display showing how many feet it is, then it suddenly freeze and I'll realize it's said a few hundred feet for the last mile or so, oh snap that's because it's frozen.
Reply With Quote
  #25  
Old 1 Week Ago
poolmon poolmon is offline
Senior Member
 
Join Date: Jul 2009
Posts: 1,380
Default

Quote:
Originally Posted by CharliesTheMan View Post
I've noticed that my lock-ups are occurring on a speed trap alert often. The strange thing is, it's locked up twice on me going in the same direction (at least two or three times) but coming back, it doesn't always do it in that spot.

It seems to be when I'm approaching something like a speed trap, and it's on the display showing how many feet it is, then it suddenly freeze and I'll realize it's said a few hundred feet for the last mile or so, oh snap that's because it's frozen.
Is it a Speep Trap or a Speed Camera that the voice alert is reporting when it locks up?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:44 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.